aboutsummaryrefslogtreecommitdiffstats
path: root/audio/flac/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/flac/Makefile')
-rw-r--r--audio/flac/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index 16d547f4bece..a9a2dd879134 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= flac
-PORTVERSION= 0.8
+PORTVERSION= 0.9
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,6 +20,8 @@ BUILD_DEPENDS+= xmms-config:${PORTSDIR}/audio/xmms
LIB_DEPENDS+= xmms.1:${PORTSDIR}/audio/xmms
.endif
+ONLY_FOR_ARCHS= i386
+
USE_LIBTOOL= yes
USE_AUTOMAKE= yes
USE_AUTOCONF= yes
@@ -33,7 +35,11 @@ INSTALLS_SHLIB= yes
post-install:
.if !defined(NO_PORTDOCS)
${MKDIR} ${PREFIX}/share/doc/flac
- ${CP} -R ${WRKSRC}/doc/ ${PREFIX}/share/doc/flac
+ ${MKDIR} ${PREFIX}/share/doc/flac/images
+ ${CP} ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/flac
+.for file in logo.jpg 1x1.gif
+ ${CP} ${WRKSRC}/doc/images/${file} ${PREFIX}/share/doc/flac/images
+.endfor
.endif
.include <bsd.port.mk>