aboutsummaryrefslogtreecommitdiffstats
path: root/audio/flac123/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/flac123/Makefile')
-rw-r--r--audio/flac123/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/audio/flac123/Makefile b/audio/flac123/Makefile
index 023116bed6fb..3b8287f3de01 100644
--- a/audio/flac123/Makefile
+++ b/audio/flac123/Makefile
@@ -10,12 +10,13 @@ MASTER_SITES= SF/flac-tools/${PORTNAME}/${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Command-line player for flac audio files
-LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac \
- ao.4:${PORTSDIR}/audio/libao \
- popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
+ libao.so:${PORTSDIR}/audio/libao \
+ libpopt.so:${PORTSDIR}/devel/popt
+
+OPTIONS_DEFINE= DOCS
USES= gmake
-NO_STAGE= yes
GNU_CONFIGURE= yes
PORTDOCS= README.remote
@@ -26,11 +27,9 @@ post-patch:
${WRKSRC}/configure
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>