aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gnome-media/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gnome-media/Makefile')
-rw-r--r--audio/gnome-media/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/audio/gnome-media/Makefile b/audio/gnome-media/Makefile
index 74e21e8ff561..1f247fe929b3 100644
--- a/audio/gnome-media/Makefile
+++ b/audio/gnome-media/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/gnome-media/Makefile,v 1.123 2008/09/24 03:17:39 mezz Exp $
+# $MCom: ports/audio/gnome-media/Makefile,v 1.130 2009/03/17 22:20:16 kwm Exp $
#
PORTNAME= gnome-media
-PORTVERSION= 2.24.0.1
+PORTVERSION= 2.26.0
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -15,6 +15,10 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Multimedia applications for the GNOME 2 desktop
+LIB_DEPENDS= pulse.0:${PORTSDIR}/audio/pulseaudio \
+ canberra-gtk.0:${PORTSDIR}/audio/libcanberra \
+ unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
+
USE_BZIP2= yes
USE_GETTEXT= yes
INSTALLS_OMF= yes
@@ -23,15 +27,14 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop nautiluscdburner
+USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop
USE_GSTREAMER= cdparanoia esound gconf good
CONFIGURE_ARGS= --enable-ipv6
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= gnome-audio-profiles.schemas \
- gnome-sound-recorder.schemas \
- gnome-volume-control.schemas
+ gnome-sound-recorder.schemas
post-patch:
@${REINPLACE_CMD} -e 's|[$$][(]CDROM_HOST[)]|freebsd|g' \