aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gogglesmm
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gogglesmm')
-rw-r--r--audio/gogglesmm/Makefile50
1 files changed, 13 insertions, 37 deletions
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index 589a5f1ef0a3..524d5bb9469a 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -38,49 +38,25 @@ MAN1= gogglesmm.1
PORTDOCS= README AUTHORS
-.include <bsd.port.options.mk>
+FOX16_LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16
+FOX17_LIB_DEPENDS= FOX-1.7:${PORTSDIR}/x11-toolkits/fox17
-.if ${PORT_OPTIONS:MFOX16}
-LIB_DEPENDS+= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16
-.endif
+GCRYPT_LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
+GCRYPT_CONFIGURE_ON= --with-md5=gcrypt
+GCRYPT_CONFIGURE_OFF= --with-md5=internal
-.if ${PORT_OPTIONS:MFOX17}
-LIB_DEPENDS+= FOX-1.7:${PORTSDIR}/x11-toolkits/fox17
-.endif
+DBUS_LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
+DBUS_CONFIGURE_OFF= --with-dbus
-.if ${PORT_OPTIONS:MGCRYPT}
-LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
-CONFIGURE_ARGS+= --with-md5=gcrypt
-.else
-CONFIGURE_ARGS+= --with-md5=internal
-.endif
+CURL_LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_OFF= --without-curl
-.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
-.else
-CONFIGURE_ARGS+= --without-dbus
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_OFF= --disable-nls
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
-.else
-CONFIGURE_ARGS+= --without-curl
-.endif
+NEWREMOTE_CONFIGURE_OFF= --without-new-remote
-.if ${PORT_OPTIONS:MNLS}
-PLIST_SUB= NLS=""
-USES+= gettext
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
-
-.if empty(PORT_OPTIONS:MNEWREMOTE)
-CONFIGURE_ARGS+=--without-new-remote
-.endif
-
-post-patch:
- @${ECHO_CMD} ${SUBPORT}
+.include <bsd.port.options.mk>
pre-install:
@${MKDIR} ${PREFIX}/share/applications