aboutsummaryrefslogtreecommitdiffstats
path: root/audio/grip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/grip/Makefile')
-rw-r--r--audio/grip/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index 61e906ac486c..d5aec468cc7d 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -6,8 +6,7 @@
# $MCom: ports/audio/grip/Makefile,v 1.4 2007/05/19 21:35:57 marcus Exp $
PORTNAME= grip
-PORTVERSION= 3.2.0
-PORTREVISION= 25
+PORTVERSION= 3.3.1
CATEGORIES= audio
MASTER_SITES= SF
@@ -20,7 +19,6 @@ LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
USE_XORG= x11
USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui vte
USE_GMAKE= yes
-USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:22
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -86,6 +84,14 @@ RUN_DEPENDS+= bladeenc:${PORTSDIR}/audio/bladeenc
RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
pre-everything::
.if !defined(WITH_CDROM_DEVICE)
@${ECHO_MSG} "===> The default CDROM device is ${DEFAULT_CDROM_DEVICE}"