aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libofa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/libofa/Makefile')
-rw-r--r--audio/libofa/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/audio/libofa/Makefile b/audio/libofa/Makefile
new file mode 100644
index 000000000000..e362f01a0b00
--- /dev/null
+++ b/audio/libofa/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libofa
+# Date created: 2006-04-01
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libofa
+PORTVERSION= 0.9.1
+CATEGORIES= audio
+MASTER_SITES= http://www.musicdns.org/themes/musicdns_org/downloads/
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= The Open Fingerprint Architecture Library
+
+LIB_DEPENDS= fftw3.3:${PORTSDIR}/math/fftw3 \
+ expat.6:${PORTSDIR}/textproc/expat2 \
+ curl.3:${PORTSDIR}/ftp/curl
+
+USE_GNOME= pkgconfig
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-configure:
+ @${REINPLACE_CMD} -e "s|pcdir =.*|pcdir = ${PREFIX}/libdata/pkgconfig|g" \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>