aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libsndfile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/libsndfile')
-rw-r--r--audio/libsndfile/Makefile25
-rw-r--r--audio/libsndfile/distinfo1
-rw-r--r--audio/libsndfile/pkg-comment1
-rw-r--r--audio/libsndfile/pkg-descr5
-rw-r--r--audio/libsndfile/pkg-plist16
5 files changed, 48 insertions, 0 deletions
diff --git a/audio/libsndfile/Makefile b/audio/libsndfile/Makefile
new file mode 100644
index 000000000000..bc581522bd30
--- /dev/null
+++ b/audio/libsndfile/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: libsndfile
+# Date created: Jul 20, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsndfile
+PORTVERSION= 0.0.23
+CATEGORIES= audio
+MASTER_SITES= http://www.zip.com.au/~erikd/libsndfile/
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/libsndfile/distinfo b/audio/libsndfile/distinfo
new file mode 100644
index 000000000000..d2b8563aa938
--- /dev/null
+++ b/audio/libsndfile/distinfo
@@ -0,0 +1 @@
+MD5 (libsndfile-0.0.23.tar.gz) = f77f152265ae8091b25bd4bc8ee083a0
diff --git a/audio/libsndfile/pkg-comment b/audio/libsndfile/pkg-comment
new file mode 100644
index 000000000000..9891c4143999
--- /dev/null
+++ b/audio/libsndfile/pkg-comment
@@ -0,0 +1 @@
+Reading and writing files containing sampled sound (like WAV or AIFF)
diff --git a/audio/libsndfile/pkg-descr b/audio/libsndfile/pkg-descr
new file mode 100644
index 000000000000..6fc022254a2f
--- /dev/null
+++ b/audio/libsndfile/pkg-descr
@@ -0,0 +1,5 @@
+Libsndfile is a C library for reading and writing files containing sampled
+sound (such as MS Windows WAV and the Apple/SGI AIFF format) through one
+standard library interface.
+
+WWW: http://www.zip.com.au/~erikd/libsndfile/
diff --git a/audio/libsndfile/pkg-plist b/audio/libsndfile/pkg-plist
new file mode 100644
index 000000000000..c6372fdf9305
--- /dev/null
+++ b/audio/libsndfile/pkg-plist
@@ -0,0 +1,16 @@
+include/sndfile.h
+lib/libsndfile.a
+lib/libsndfile.la
+lib/libsndfile.so
+lib/libsndfile.so.0
+%%PORTDOCS%%share/doc/libsndfile/ChangeLog
+%%PORTDOCS%%share/doc/libsndfile/Makefile
+%%PORTDOCS%%share/doc/libsndfile/Makefile.am
+%%PORTDOCS%%share/doc/libsndfile/Makefile.in
+%%PORTDOCS%%share/doc/libsndfile/NEWS
+%%PORTDOCS%%share/doc/libsndfile/api.html
+%%PORTDOCS%%share/doc/libsndfile/bugs.html
+%%PORTDOCS%%share/doc/libsndfile/index.html
+%%PORTDOCS%%share/doc/libsndfile/libsndfile.jpg
+%%PORTDOCS%%share/doc/libsndfile/new_file_type.HOWTO
+%%PORTDOCS%%share/doc/libsndfile/sfinfo.html