aboutsummaryrefslogtreecommitdiffstats
path: root/audio/lmms/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/lmms/Makefile')
-rw-r--r--audio/lmms/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/lmms/Makefile b/audio/lmms/Makefile
index 003ba382deb9..34d4434bb039 100644
--- a/audio/lmms/Makefile
+++ b/audio/lmms/Makefile
@@ -6,14 +6,12 @@ PORTVERSION= 0.4.15
PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= audio
-MASTER_SITES= SF
MAINTAINER= rodrigo@FreeBSD.org
COMMENT= All-in-one sequencer, drum machine, sampler, and more
LICENSE= GPLv2
-BROKEN= Unfetchable
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
libfluidsynth.so:${PORTSDIR}/audio/fluidsynth \
@@ -25,7 +23,7 @@ LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac \
RUN_DEPENDS= ${LOCALBASE}/share/ladspa/rdf/caps.rdf:${PORTSDIR}/audio/caps-plugins \
${LOCALBASE}/lib/ladspa/cmt.so:${PORTSDIR}/audio/cmt \
${LOCALBASE}/share/ladspa/rdf/swh-plugins.rdf:${PORTSDIR}/audio/swhplugins \
- ${LOCALBASE}/share/ladspa/rdf/tap-plugins.rdf:${PORTSDIR}/audio/tap-plugins \
+ ${LOCALBASE}/share/ladspa/rdf/tap-plugins.rdf:${PORTSDIR}/audio/tap-plugins
OPTIONS_DEFINE= JACK PULSEAUDIO SDL
@@ -33,7 +31,10 @@ USE_LDCONFIG= yes
USE_XORG= xft
USE_QT4= corelib gui xml moc_build uic_build rcc_build \
qmake_build
-USES= cmake pkgconfig tar:bzip2 desktop-file-utils shared-mime-info dos2unix
+USE_GITHUB= yes
+GH_ACCOUNT= LMMS
+GH_TAGNAME= v${PORTVERSION}
+USES= cmake desktop-file-utils dos2unix pkgconfig shared-mime-info
CMAKE_ARGS= -DWANT_ALSA:BOOL=OFF \
-DWANT_CALF:BOOL=OFF \
-DWANT_CAPS:BOOL=OFF \
@@ -79,6 +80,5 @@ post-install:
${STAGEDIR}${PREFIX}/share/pixmaps/lmms.png
# make it setuid-root to be able to set realtime priority
# (root privileges are dropped in the main routine)
- ${CHMOD} u+s ${STAGEDIR}${PREFIX}/bin/lmms
.include <bsd.port.mk>