aboutsummaryrefslogtreecommitdiffstats
path: root/audio/lollypop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/lollypop/Makefile')
-rw-r--r--audio/lollypop/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/audio/lollypop/Makefile b/audio/lollypop/Makefile
index cd4255cec761..6d1ac720fd9a 100644
--- a/audio/lollypop/Makefile
+++ b/audio/lollypop/Makefile
@@ -13,14 +13,14 @@ COMMENT= Play and organize your music collection
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.8:databases/py-sqlite3 \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.8:databases/py-sqlite3@${PY_FLAVOR} \
itstool:textproc/itstool \
- ${PYTHON_PKGNAMEPREFIX}dbus>=1.1.1:devel/py3-dbus \
- ${PYTHON_PKGNAMEPREFIX}gstreamer1>=1.4.0:multimedia/py3-gstreamer1
+ ${PYTHON_PKGNAMEPREFIX}dbus>=1.1.1:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gstreamer1>=1.4.0:multimedia/py-gstreamer1@${PY_FLAVOR}
LIB_DEPENDS= libnotify.so:devel/libnotify \
libtotem-plparser.so:multimedia/totem-pl-parser
-USES= shebangfix python:3 pkgconfig gettext gmake sqlite tar:xz
+USES= shebangfix python:3.4+ pkgconfig gettext gmake sqlite tar:xz
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk30 py3gobject3 introspection:build intltool intlhack
USE_GSTREAMER1= yes mpg123 ogg flac opus libav faad good speex
@@ -36,11 +36,4 @@ PULSEAUDIO_USE= gstreamer1=pulse
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
-
-.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
- ${PYTHON_VER} != ${PYTHON_DEFAULT}
-IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>