aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mp3c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mp3c/Makefile')
-rw-r--r--audio/mp3c/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/audio/mp3c/Makefile b/audio/mp3c/Makefile
index b82d999c37ce..b60ee4d948e8 100644
--- a/audio/mp3c/Makefile
+++ b/audio/mp3c/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mp3c
-PORTVERSION= 0.27
-PORTREVISION= 1
+PORTVERSION= 0.31
CATEGORIES= audio
MASTER_SITES= ftp://ftp.wspse.de/linux/wspse/:src
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:src \
@@ -17,16 +16,27 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= joris@vandalon.nl
COMMENT= A CD to mp3c converter with a console frontend
-RUN_DEPENDS= dagrab:${PORTSDIR}/audio/dagrab \
- gogo:${PORTSDIR}/audio/gogo \
- id3tool:${PORTSDIR}/audio/id3tool
+RUN_DEPENDS= mp3info:${PORTSDIR}/audio/mp3info
+USE_CDRTOOLS= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= "--prefix=${PREFIX}"
MAN1= mp3c.1
MANCOMPRESSED= no
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|rcd0d|acd0|g' ${WRKSRC}/src/conf.c
+ @${REINPLACE_CMD} -e 's|/dev/cdrom|/dev/acd0|g' ${WRKSRC}/src/conf.c
+
post-install:
${INSTALL_SCRIPT} ${DISTDIR}/cdrip.sh ${LOCALBASE}/bin