aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mp3splt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mp3splt/Makefile')
-rw-r--r--audio/mp3splt/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/audio/mp3splt/Makefile b/audio/mp3splt/Makefile
index 3bd8e1854397..3a2057daf793 100644
--- a/audio/mp3splt/Makefile
+++ b/audio/mp3splt/Makefile
@@ -2,18 +2,22 @@
# $FreeBSD$
PORTNAME= mp3splt
-PORTVERSION= 2.5.1
+PORTVERSION= 2.5.2
CATEGORIES= audio
MASTER_SITES= SF/mp3splt/${PORTNAME}/${PORTVERSION}
MAINTAINER= citrin@citrin.ru
COMMENT= Utility to split MP3 and Ogg files (via CUE sheets)
+LICENSE= GPLv2
+
LIB_DEPENDS= mp3splt:${PORTSDIR}/audio/libmp3splt
+USES= pkgconfig:build
USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-oggsplt_symlink --disable-mp3splttest
+CONFIGURE_ARGS= --enable-oggsplt_symlink
+CONFIGURE_ENV+= PKG_CONFIG_PATH=${LOCALBASE}/lib/pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -38,12 +42,4 @@ PLIST_DIRSTRY+= share/locale/de_DE
CONFIGURE_ARGS+= --disable-nls
.endif
-post-patch:
-.if ${OSVERSION} < 800067
-# getline() is GNU extension which FreeBSD only recently adopted
- @${REINPLACE_CMD} -E \
- 's:getline\(&(.+, )&(.+, .+\) == )-1:fgets(\1\2NULL:' \
- ${WRKSRC}/src/freedb.c
-.endif
-
.include <bsd.port.mk>