aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mpg123/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mpg123/Makefile')
-rw-r--r--audio/mpg123/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index 268a0d5ef2d8..18017d9628c6 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -99,4 +99,9 @@ OPT_ARCH?= i586
MAKE_ARGS+= OPT_ARCH=${OPT_ARCH}
.endif
+post-patch:
+ @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
+ ${WRKSRC}/audio_oss.c > ${WRKSRC}/audio_oss.c.new
+ @${MV} ${WRKSRC}/audio_oss.c.new ${WRKSRC}/audio_oss.c
+
.include <bsd.port.post.mk>