aboutsummaryrefslogtreecommitdiffstats
path: root/audio/penguinsap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/penguinsap/Makefile')
-rw-r--r--audio/penguinsap/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/penguinsap/Makefile b/audio/penguinsap/Makefile
index a5d5405553e7..37a39bfc8c76 100644
--- a/audio/penguinsap/Makefile
+++ b/audio/penguinsap/Makefile
@@ -22,12 +22,12 @@ PLIST_FILES= bin/sap
.include <bsd.port.pre.mk>
-_CLANG!= clang --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+_CLANG!= ${CXX} --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+ISCLANG= ${_CLANG:M[34][0-9]}
-.if ${CXX:T} != "clang++"
-.if ${_CLANG} < 33
-CXXFLAGS+= --no-exceptions
-.endif
+# clang can build this without -fno-exceptions
+.if empty(ISCLANG)
+CXXFLAGS+= -fno-exceptions
.endif
post-patch: