aboutsummaryrefslogtreecommitdiffstats
path: root/audio/qsynth
diff options
context:
space:
mode:
Diffstat (limited to 'audio/qsynth')
-rw-r--r--audio/qsynth/Makefile27
-rw-r--r--audio/qsynth/distinfo3
-rw-r--r--audio/qsynth/pkg-descr6
-rw-r--r--audio/qsynth/pkg-plist4
4 files changed, 40 insertions, 0 deletions
diff --git a/audio/qsynth/Makefile b/audio/qsynth/Makefile
new file mode 100644
index 000000000000..ea809da3bc78
--- /dev/null
+++ b/audio/qsynth/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: qsynth
+# Date created: 2007-11-17
+# Whom: lazyklimm <lazyklimm@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qsynth
+DISTVERSION= 0.3.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= qsynth
+
+MAINTAINER= lazyklimm@gmail.com
+COMMENT= Qt fluidsynth front-end application
+
+LIB_DEPENDS= fluidsynth:${PORTSDIR}/audio/fluidsynth
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc uic rcc gui xml
+CFLAGS+= ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}
+CONFIGURE_ARGS+=ac_cv_path_ac_moc=${LOCALBASE}/bin/moc-qt4 ac_cv_path_ac_uic=${LOCALBASE}/bin/uic-qt4 \
+ ac_cv_path_ac_qmake=${LOCALBASE}/bin/qmake-qt4
+
+.include <bsd.port.mk>
diff --git a/audio/qsynth/distinfo b/audio/qsynth/distinfo
new file mode 100644
index 000000000000..1a0bbcd49ea8
--- /dev/null
+++ b/audio/qsynth/distinfo
@@ -0,0 +1,3 @@
+MD5 (qsynth-0.3.1.tar.gz) = 41de4b244cd896a1150101855bafbbb8
+SHA256 (qsynth-0.3.1.tar.gz) = 56d0c14f85a9469df97df2d813860a471a71e2206e7e11365e37a3be028a2aa6
+SIZE (qsynth-0.3.1.tar.gz) = 137632
diff --git a/audio/qsynth/pkg-descr b/audio/qsynth/pkg-descr
new file mode 100644
index 000000000000..adca511fc944
--- /dev/null
+++ b/audio/qsynth/pkg-descr
@@ -0,0 +1,6 @@
+Qsynth is a fluidsynth GUI front-end application written in C++ around the Qt4
+toolkit using Qt Designer. Eventually it may evolve into a softsynth management
+application allowing the user to control and manage a variety of command line
+softsynth but for the moment it wraps the excellent FluidSynth.
+
+WWW: http://qsynth.sourceforge.net/
diff --git a/audio/qsynth/pkg-plist b/audio/qsynth/pkg-plist
new file mode 100644
index 000000000000..ef65ecdae79e
--- /dev/null
+++ b/audio/qsynth/pkg-plist
@@ -0,0 +1,4 @@
+bin/qsynth
+share/pixmaps/qsynth.png
+share/applications/qsynth.desktop
+@dirrmtry share/applications