aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rezound
diff options
context:
space:
mode:
Diffstat (limited to 'audio/rezound')
-rw-r--r--audio/rezound/Makefile34
-rw-r--r--audio/rezound/files/patch-src_backend_CSound_defs.h13
2 files changed, 31 insertions, 16 deletions
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index d504828288e4..2d8fc3662c7d 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rezound
DISTVERSION= 0.12.3beta
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/ReZound/${DISTVERSION}
@@ -23,58 +23,60 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-alsa
+MAKE_JOBS_UNSAFE= yes
-OPTIONS= LARGEFILE "Enable 64-bit I/O support (not yet!)" off \
+OPTIONS= LARGEFILE "Enable 64-bit file I/O support" off \
JACK "Enable Jack audio server support" off \
- AUDIOFILE "Enable Audio File Library support" on \
+ AUDIOFILE "Enable Audio File library support" on \
PORTAUDIO "Enable PortAudio support" on \
OGG "Enable OGG support" on \
VORBIS "Enable Vorbis support" on \
FLAC "Enable FLAC support" on \
FFTW "Enable FFTW support" off \
SOUNDTOUCH "Enable SoundTouch features" on \
- LADSPA "Enable LADSPA plugin support" on \
+ LADSPA "Enable LADSPA plugins support" on \
LAME "Enable loading and saving MP3 files" on \
- CDRDAO "Enable burning audio files to CD" off \
- NLS "Enable Native Language Support" on
+ CDRDAO "Enable burning audio files to CD" off
+# BROKEN_NLS "Enable Native Language Support" on
+# NLS support is broken as of recent versions of libstdc++; rezound dies at
+# startup with "locale::facet::_S_create_c_locale name not valid" exception
.include <bsd.port.pre.mk>
.if defined(WITH_LARGEFILE)
CONFIGURE_ARGS+= --enable-largefile
-BROKEN= no expl(), logl(), nearbyintl(), etc
.endif
.if defined(WITH_JACK)
-LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
.endif
.if defined(WITH_AUDIOFILE)
-LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS+= audiofile:${PORTSDIR}/audio/libaudiofile
.endif
.if defined(WITH_PORTAUDIO)
-LIB_DEPENDS+= portaudio.0:${PORTSDIR}/audio/portaudio
+LIB_DEPENDS+= portaudio:${PORTSDIR}/audio/portaudio
.endif
.if defined(WITH_OGG)
-LIB_DEPENDS+= ogg.7:${PORTSDIR}/audio/libogg
+LIB_DEPENDS+= ogg:${PORTSDIR}/audio/libogg
.endif
.if defined(WITH_VORBIS)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
.endif
.if defined(WITH_FLAC)
-LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
.endif
.if defined(WITH_FFTW)
-LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
+LIB_DEPENDS+= fftw:${PORTSDIR}/math/fftw
.endif
.if defined(WITH_SOUNDTOUCH)
-LIB_DEPENDS+= SoundTouch.0:${PORTSDIR}/audio/soundtouch
+LIB_DEPENDS+= SoundTouch:${PORTSDIR}/audio/soundtouch
.endif
.if defined(WITH_LADSPA)
@@ -91,7 +93,7 @@ RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
RUN_DEPENDS+= cdrdao:${PORTSDIR}/sysutils/cdrdao
.endif
-.if !defined(WITHOUT_NLS)
+.if defined(WITH_BROKEN_NLS) # Enable only if you know what you're doing
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/audio/rezound/files/patch-src_backend_CSound_defs.h b/audio/rezound/files/patch-src_backend_CSound_defs.h
new file mode 100644
index 000000000000..c45e4e859bd7
--- /dev/null
+++ b/audio/rezound/files/patch-src_backend_CSound_defs.h
@@ -0,0 +1,13 @@
+--- src/backend/CSound_defs.h.orig 2004-06-18 10:45:47.000000000 +0800
++++ src/backend/CSound_defs.h 2012-07-06 14:10:05.000000000 +0800
+@@ -50,6 +50,10 @@
+ #define MAX_LENGTH (0x7fffffffffffffffLL-(1024LL*1024LL))
+
+ #include <math.h>
++ extern "C" {
++ long double logl(long double);
++ long double expl(long double);
++ }
+ #define sample_fpos_floor(a) (floorl(a))
+ #define sample_fpos_ceil(a) (ceill(a))
+ #define sample_fpos_round(a) (nearbyintl(a))