aboutsummaryrefslogtreecommitdiffstats
path: root/audio/rioutil/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/rioutil/Makefile')
-rw-r--r--audio/rioutil/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/audio/rioutil/Makefile b/audio/rioutil/Makefile
index 1ad61d795220..f2ae6eef104f 100644
--- a/audio/rioutil/Makefile
+++ b/audio/rioutil/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A program to inferface with the Rio600, Rio800, and psa[play devices
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -26,10 +24,19 @@ MAN1= rioutil.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.ac
+USE_AUTOTOOLS= autoconf:262
+.endif
+
post-extract:
- @${RM} -f ${WRKSRC}/src/getopt*
+# @${RM} -f ${WRKSRC}/src/getopt*
# Fix for GCC 4.2
@${REINPLACE_CMD} -e 's,read_buffer = .*),(&),' \
${WRKSRC}/librioutil/rio.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>