aboutsummaryrefslogtreecommitdiffstats
path: root/audio/soundtracker/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/soundtracker/Makefile')
-rw-r--r--audio/soundtracker/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/audio/soundtracker/Makefile b/audio/soundtracker/Makefile
index 68d4005a3879..8ac8031180f5 100644
--- a/audio/soundtracker/Makefile
+++ b/audio/soundtracker/Makefile
@@ -4,7 +4,7 @@
PORTNAME= soundtracker
PORTVERSION= 0.6.8
PORTREVISION= 14
-CATEGORIES= audio gnome
+CATEGORIES= audio
MASTER_SITES= http://www.soundtracker.org/dl/%SUBDIR%/
MASTER_SITE_SUBDIR= v${PORTVERSION:R}
@@ -13,7 +13,7 @@ COMMENT= Mod player/tracking tool which supports XM and MOD formats
LICENSE= GPLv2
-LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
GNU_CONFIGURE= yes
USES= pathfix pkgconfig
@@ -23,11 +23,12 @@ USE_GNOME= esound gdkpixbuf
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= GNOME1 JACK SDL NLS
+OPTIONS_DEFINE= JACK SDL NLS
OPTIONS_DEFINE_i386= ASM
-GNOME1_DESC= Use GNOME 1.x (enables envelope editing)
ASM_DESC= Use optimized assembly (potentially unstable)
+CONFIGURE_ARGS+= --disable-gnome
+
DESKTOP_ENTRIES="SoundTracker" "Pattern-oriented music editor" \
"${PREFIX}/share/pixmaps/${PORTNAME}.xpm" \
"soundtracker" "AudioVideo;Audio;AudioVideoEditing;" false
@@ -38,13 +39,6 @@ DESKTOP_ENTRIES="SoundTracker" "Pattern-oriented music editor" \
CONFIGURE_ARGS+= --enable-asm
.endif
-.if ${PORT_OPTIONS:MGNOME}
-USE_GNOME+= gnomelibs gnomeprefix
-CONFIGURE_ARGS+= --enable-gnome
-.else
-CONFIGURE_ARGS+= --disable-gnome
-.endif
-
.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
.else