aboutsummaryrefslogtreecommitdiffstats
path: root/audio/tta/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/tta/Makefile')
-rw-r--r--audio/tta/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/audio/tta/Makefile b/audio/tta/Makefile
index 36a80111ba40..dd5f0eecdac6 100644
--- a/audio/tta/Makefile
+++ b/audio/tta/Makefile
@@ -6,27 +6,27 @@
#
PORTNAME= tta
-PORTVERSION= 3.3
+PORTVERSION= 3.4.1
CATEGORIES= audio
-MASTER_SITES= http://www.true-audio.com/ftp/
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}enc-${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
MAINTAINER= danfe@FreeBSD.org
COMMENT= The True Audio Encoder, lossless (de)compressor
-USE_ZIP= yes
-NO_WRKSUBDIR= yes
-
-LDFLAGS+= -lm
-
PROGRAM= ttaenc
-PORTDOCS= Readme
+PORTDOCS= README
PLIST_FILES= bin/ttaenc
+post-patch:
+ @${REINPLACE_CMD} -e '/ifdef _BIG_ENDIAN/s|ifdef|if _BYTE_ORDER ==|' \
+ ${WRKSRC}/${PROGRAM}.h
+
do-build:
- ${CC} ${CFLAGS} -c ${WRKSRC}/${PROGRAM}.c -o ${WRKSRC}/${PROGRAM}.o
- ${CC} ${LDFLAGS} -o ${WRKSRC}/${PROGRAM} ${WRKSRC}/${PROGRAM}.o
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/${PROGRAM} \
+ ${WRKSRC}/${PROGRAM}.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PROGRAM} ${PREFIX}/bin
ons'>-1/+27 * Clear moonlight beckons.ade2003-03-0712-6/+6 * Remove pkg-comment from remaining master/slave port sets.ade2003-03-074-2/+2 * de-pkg-commentmbr2003-03-064-2/+4 * De-pkg-comment.wosch2003-03-056-3/+3 * - MAINTAINER in standard captiondinoex2003-03-051-1/+1 * -- Move pkg-comment into Makefilenectar2003-02-262-1/+1 * Do not fail if libXrender.so doesn't exist at all.mbr2003-02-221-0/+2 * De-pkg-comment.knu2003-02-218-4/+4 * De-pkg-comment.knu2003-02-212-1/+3 * - retire pkg-commentdinoex2003-02-211-1/+0 * De-pkg-comment.knu2003-02-212-1/+1 * - add COMMENTdinoex2003-02-211-0/+1 * Make some installation notes more clear. Inspired bymbr2003-02-202-7/+24 * Add ksteak, a KDE Frontend for steakarved2003-02-175-0/+80 * Add steak, another german <-> english dictionaryarved2003-02-158-0/+129 * Remove redundant category 'editors' in slave ports.mbr2003-02-132-2/+2 * Add staroffice6 wrapper script.mbr2003-02-051-0/+15 * Fetch the sunsolve patch for inofficial distsites, we have thembr2003-02-052-13/+25 * Upgrade kde-i18n to 3.1. Note that the following modules did not get awill2003-01-294-480/+1450 * Remove a file from pkg-plist.arved2003-01-271-1/+0 * Add the language define so the handbook is actually built formbr2003-01-252-0/+2 * Add a notice about possible crashes if a localized versionmbr2003-01-242-0/+24 * Add german pkg-message and pkg-comment.mbr2003-01-234-0/+156 * - make portlint happierdinoex2003-01-233-4/+8 * Remove obsolete linembr2003-01-231-1/+0 * Update StarOffice6.0 to patchlevel 3mbr2003-01-222-10/+21 * Add USE_LANG support for german port.mbr2003-01-222-0/+10 * Update WWW.arved2003-01-191-1/+1 * Add missing filekris2003-01-141-0/+1 * Update to 3.12arved2003-01-134-20/+190 * Use tabs.obrien2003-01-081-2/+2 * "german" should be the primary category.knu2002-12-092-2/+2 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-112-2/+1 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-072-1/+2 * Port needs perl to build.edwin2002-11-042-0/+3 * Fix categories to match dir containing port. bsd.port.mk (and portlint)alane2002-10-302-2/+4 * The release notes say:trevor2002-10-151-0/+3 * I remove the linux-netscape6 ports from ports/french, ports/german,trevor2002-10-1415-728/+53 * 1. Removed comments from pkg-plist files per will's request.alane2002-10-114-2/+4 * Catch up to locale renaming (de_DE.ISO_8859-1 -> de.ISO8859-1)kris2002-09-291-3/+1 * BROKEN: Does not buildkris2002-09-211-0/+2 * Connect linux-eagle to build after repo copylioux2002-09-201-0/+1 * * Make german/linux-eagle slave port of cad/linux-eagle.obraun2002-09-194-48/+9 * Upgrade these ports to new versions. While we are here, cleanmbr2002-09-146-12/+42 * texas chainsaw kde2 massacrealane2002-09-111-2/+0 * texas chainsaw kde2 massacrealane2002-09-104-68/+0 * build aspell with dictionarydinoex2002-09-104-0/+22 * Add command line options to wfica wrappers.mbr2002-09-102-2/+2 * Fix a syntax error of the Makefile.okazaki2002-09-061-1/+1 * Assign maintainership to "Thomas E. Zander" <riggs@rrr.de> perlioux2002-08-281-1/+1 * Update to 3.0.3. Not much changed here: [1] i18n PKGNAMEs converted towill2002-08-256-8/+84 * Update to 4.09r2lioux2002-08-213-3/+3 * 1) Add localized help files to the build. Only available for french,mbr2002-08-192-0/+2 * Update 1.1 -> 1.2.nectar2002-08-132-4/+3 * Add OpenOffice.org spelling dictionary ports. They are based on MySpell,mbr2002-08-121-0/+2 * Add OpenOffice.org spelling dictionary ports. They are based on MySpell,mbr2002-08-126-2/+38 * Use MASTERDIRmbr2002-08-032-4/+4 * A trivial modification. ${LINUXBASE}/lib/ld.so, referenced in Makefile,mita2002-08-031-1/+1 * 1. Changed the lib depends on gettext to a build depends. This will meanalane2002-08-032-4/+4 * Bump PORTREVISION. KDE is fragile enough in its dependencies; we don'talane2002-08-022-0/+2 * Chase shlib rev of devel/gettextade2002-08-022-2/+2 * Fix master site.naddy2002-07-311-1/+2 * Fix typo in URLdinoex2002-07-221-1/+1 * Add install-update target to update a installed version withmbr2002-07-171-0/+5 * Upgrade to Service Pack Imbr2002-07-172-11/+31 * Add support for spelling dictionaries. Remove the pkg-plist for thembr2002-07-162-0/+2 * upgrade to 3.11ijliao2002-07-157-288/+593 * Fix MASTER_SITE_SUBDIR.will2002-07-102-2/+2 * Update to 3.0.2 -- full log available in ports/x11/kde3/Makefile,v 1.51.will2002-07-056-70/+32 * Upgrade to KDE 3.0.1. The delay in this upgrade is mainly due to thewill2002-06-166-86/+270 * Add German OpenOffice slave portmbr2002-06-153-0/+37 * Update to: unix-connect-0.94dinoex2002-06-082-2/+3 * Explict dependancy on version 7 of linux_base is not needed anymore.obrien2002-05-281-3/+2 * Remove some unused code.trevor2002-05-232-14/+2 * Update to 6.0 finalmbr2002-05-224-71/+54 * Update to 4.09r1.sobomax2002-05-223-60/+102 * Update to 6.2.3. Belatedly, I confirmed that 6.2.2 supportstrevor2002-05-174-28/+30 * As always new MD5 checksum. Citrix seems to have changed thembr2002-04-276-20/+22 * Please welcome Qt3/KDE3 to our ports tree. This includes work since thewill2002-04-2211-18/+2359 * Update Japanese, German, and French Netscape ports to version 6.2.2trevor2002-04-144-32/+30 * Update English Netscape to 6.2.2, with unknown changes. The French,trevor2002-03-282-0/+4 * Install the program 'dict' as 'de-dict', so the port canwosch2002-03-102-1/+12 * Use the German home page rather than the English one.trevor2002-03-042-2/+2 * Remove this file, since it will now be generated entirely in thetrevor2002-03-042-6/+0 * Add new port of Netscape 6 (Linux binary) with German localization.trevor2002-03-0421-0/+1373 * Don't try to use ${AWK}, ${GREP} or ${TAIL} in != before includingfenner2002-01-301-2/+3 * Don't try to use ${AWK}, ${GREP} and ${TAIL} in != before includingfenner2002-01-301-2/+2 * Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;knu2002-01-295-10/+10 * Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;knu2002-01-291-2/+2 * Change some defines from "YES" to "yes"dinoex2002-01-281-1/+1 * Mark port broken (until April when 6.0 get's released :-)mbr2002-01-231-0/+1 * Fix the package list and remove netscape plugin if installedmbr2002-01-224-346/+190 * Fix the plugin install. Look if there is a linux netscape installedmbr2002-01-224-16/+112 * Add new ports: french/koffice-i18n, german/koffice-i18n and japanese/koffice-...sada2002-01-214-0/+52 * - make portlint happierdinoex2002-01-062-4/+4 * Add message explaining that after installation the user have to run the programsobomax2001-12-292-4/+12 * Hardcode another /cdrom, since the define is not overwritten by thembr2001-12-281-3/+1 * Add linux-eagle , an easy to use, yet powerful tool for designingsobomax2001-12-275-0/+703 * Hardcode the /cdrom path, until bsd.port.mk is fixed. I don't knowmbr2001-12-251-0/+1 * Maintainer is now a committermbr2001-12-242-2/+2 * Change my email address, upgrade to latest version and fixmbr2001-12-246-24/+42 * Bump PORTREVISION due to recent update of sunsolve patch.demon2001-12-201-0/+1 * Update for new sunsolve patch.demon2001-12-18