aboutsummaryrefslogtreecommitdiffstats
path: root/audio/wavegain/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/wavegain/Makefile')
-rw-r--r--audio/wavegain/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/audio/wavegain/Makefile b/audio/wavegain/Makefile
index 282afcb8b530..ade0db9e7efc 100644
--- a/audio/wavegain/Makefile
+++ b/audio/wavegain/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}srcs${EXTRACT_SUFFIX}
MAINTAINER= darcsis@gmail.com
COMMENT= A program that applies ReplayGain to wave files
-LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
USES= gmake
USE_ZIP= yes
@@ -26,6 +26,9 @@ WRKSRC= ${WRKDIR}/WaveGain-${PORTVERSION}
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/Makefile.linux
+
do-configure:
@cd ${WRKSRC} && ${CP} Makefile.linux Makefile