aboutsummaryrefslogtreecommitdiffstats
path: root/audio/wsoundserver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/wsoundserver/Makefile')
-rw-r--r--audio/wsoundserver/Makefile27
1 files changed, 17 insertions, 10 deletions
diff --git a/audio/wsoundserver/Makefile b/audio/wsoundserver/Makefile
index 42c6e6b55411..b407037e773c 100644
--- a/audio/wsoundserver/Makefile
+++ b/audio/wsoundserver/Makefile
@@ -1,28 +1,35 @@
-# New ports collection makefile for: wmsound
+# New ports collection makefile for: wsoundserver
# Date created: 9 December 1998
# Whom: gljohns@bellsouth.net
#
# $FreeBSD$
#
-PORTNAME= wmsound
-PORTVERSION= 0.9.5
+PORTNAME= wsoundserver
+PORTVERSION= 0.4.0
CATEGORIES= audio windowmaker
MASTER_SITES= ftp://shadowmere.student.utwente.nl/pub/WindowMaker/
+DISTNAME= WSoundServer-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= wmaker:${PORTSDIR}/x11-wm/windowmaker
-LIB_DEPENDS= PropList.2:${PORTSDIR}/devel/libPropList
+LIB_DEPENDS= PropList.2:${PORTSDIR}/devel/libPropList \
+ audiofile.0:${PORTSDIR}/audio/libaudiofile \
+ dockapp.1:${PORTSDIR}/x11-wm/libdockapp
-USE_IMAKE= yes
-NO_INSTALL_MANPAGES= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+MAKE_ARGS= "-E CFLAGS"
+
+MAN1= get-wsound-flags.1x getsoundset.1x setsoundset.1x \
+ wsoundplay.1x wsoundserver.1x
post-install:
${SH} ${FILESDIR}/configure > ${WRKDIR}/WMSound
- ${MKDIR} ${PREFIX}/share/WindowMaker/Defaults
+ ${MKDIR} ${PREFIX}/etc/WindowMaker
${INSTALL_DATA} ${WRKDIR}/WMSound \
- ${PREFIX}/share/WindowMaker/Defaults/WMSound
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+ ${PREFIX}/etc/WindowMaker/WMSound
.include <bsd.port.mk>