aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-flac/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xmms-flac/Makefile')
-rw-r--r--audio/xmms-flac/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/audio/xmms-flac/Makefile b/audio/xmms-flac/Makefile
index 066bebc3236d..e8643e5c269a 100644
--- a/audio/xmms-flac/Makefile
+++ b/audio/xmms-flac/Makefile
@@ -7,11 +7,14 @@
PORTNAME= xmms-flac
PORTVERSION= 1.1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= flac
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:sf/} \
+ ${MASTER_SITE_LOCAL:S/$/:local/}
+MASTER_SITE_SUBDIR= flac/:sf naddy/:local
DISTNAME= flac-${PORTVERSION}
+DISTFILES= ${EXTRACT_ONLY}:sf flac-alloc.h:local
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= naddy@FreeBSD.org
COMMENT= XMMS input plugin for playing FLAC files
@@ -28,6 +31,9 @@ MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
MAKE_ENV= MAKEOBJDIR=/nonexistent # ignore ${WRKSRC}/obj
MAKEFILE= ${FILESDIR}/Makefile
+post-extract:
+ @${CP} ${DISTDIR}/flac-alloc.h ${WRKSRC}/include/share/alloc.h
+
# XXX
post-install:
${RM} ${PREFIX}/lib/xmms/Input/libxmms-flac.la