aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-infopipe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xmms-infopipe/Makefile')
-rw-r--r--audio/xmms-infopipe/Makefile39
1 files changed, 26 insertions, 13 deletions
diff --git a/audio/xmms-infopipe/Makefile b/audio/xmms-infopipe/Makefile
index 0bfa5fdd8dc0..08becb61a277 100644
--- a/audio/xmms-infopipe/Makefile
+++ b/audio/xmms-infopipe/Makefile
@@ -1,23 +1,36 @@
# New ports collection makefile for: xmms-infopipe
-# Date created: 14 July 2003
-# Whom: mig
+# Date created: 14 July 2003
+# Whom: mig
#
# $FreeBSD$
#
-PORTNAME= xmms-infopipe
-PORTVERSION= 1.3
-CATEGORIES= audio
-MASTER_SITES= http://www.beastwithin.org/users/wwwwolf/code/xmms/
-MASTER_SITE_SUBDIR= ${PORTNAME}
+PORTNAME= xmms-infopipe
+PORTVERSION= 1.3
+PORTREVISION= 1
+CATEGORIES= audio
+MASTER_SITES= http://www.beastwithin.org/users/wwwwolf/code/xmms/
+MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= mig@mig-29.net
-COMMENT= Create a named pipe to retrive xmms info about currently playing song
+MAINTAINER= mig@mig-29.net
+COMMENT= Create a named pipe to retrive xmms info about currently playing song
-RUN_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
-USE_X_PREFIX= yes
-USE_GNOME= gtk12
-GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+USE_GNOME= gtk12
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+LIBDIR?= ${PREFIX}/lib/xmms/General
+SRCLIBDIR?= src/.libs
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%X11BASE%%/lib/xmms/General
+
+do-install:
+ cd ${WRKSRC}/${SRCLIBDIR};\
+ ${MKDIR} ${LIBDIR};\
+ ${INSTALL_PROGRAM} libinfopipe-1.3.so.1 ${LIBDIR}/libinfopipe.so
.include <bsd.port.mk>