aboutsummaryrefslogtreecommitdiffstats
path: root/audio/xmms-nsf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/xmms-nsf/Makefile')
-rw-r--r--audio/xmms-nsf/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/audio/xmms-nsf/Makefile b/audio/xmms-nsf/Makefile
new file mode 100644
index 000000000000..8d02f84efc85
--- /dev/null
+++ b/audio/xmms-nsf/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: xmms-nsf
+# Date created: 18 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-nsf
+PORTVERSION= 0.0.3
+CATEGORIES= audio
+MASTER_SITES= http://optronic.sourceforge.net/files/ \
+ http://critical.ch/distfiles/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= XMMS input-plugin for playing Nintendo(TM) NSF audio files
+
+BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+USE_LIBTOOL_VER=13
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+ONLY_FOR_ARCHS= i386 amd64
+
+CFLAGS+= -fPIC
+
+PLIST_FILES= lib/xmms/Input/libnsf.so lib/xmms/Input/libnsf.la
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|' \
+ ${WRKSRC}/src/nes/nestypes.h
+
+post-install:
+ @${SED} -e 's|%%VERSION%%|${PORTVERSION}|' ${PKGMESSAGE}
+
+.include <bsd.port.mk>