aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/exaile-devel/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/audio/exaile-devel/Makefile b/audio/exaile-devel/Makefile
index 2c0cf4f47a5d..1d64ae285ec6 100644
--- a/audio/exaile-devel/Makefile
+++ b/audio/exaile-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exaile
DISTVERSION= 0.2.99.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.exaile.org/files/ \
http://wickedmachine.net/~jsa/FreeBSD/distfiles/
@@ -29,7 +29,8 @@ CONFLICTS= exaile-0.2.[0-9][0-8]* exaile-0.3.*
# The reality with these options is that they all will be autodetected and used
# if already installed. These just force Exaile to bring them in as well.
-OPTIONS= BAD "Install bad gstreamer plugins" On\
+OPTIONS= BAD "Install bad GStreamer plugins" On \
+ BDB "Install Python Berkley DB module" On \
CDDB "Lookup CD information within Exaile" On \
DBUS "Rely on Python D-Bus bindings" On \
HAL "Force depend on HAL" On \
@@ -41,6 +42,10 @@ OPTIONS= BAD "Install bad gstreamer plugins" On\
USE_GSTREAMER+= bad
.endif
+.if !defined(WITHOUT_BDB)
+RUN_DEPENDS+= py*-bsddb>=2.5:${PORTSDIR}/databases/py-bsddb
+.endif
+
.if !defined(WITHOUT_CDDB)
RUN_DEPENDS+= py*-cddb>=1.4:${PORTSDIR}/audio/py-cddb
.endif