aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/hawkvoice/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/hawkvoice/Makefile b/audio/hawkvoice/Makefile
index 98f5ac4bf9d3..bc7323e68666 100644
--- a/audio/hawkvoice/Makefile
+++ b/audio/hawkvoice/Makefile
@@ -32,6 +32,10 @@ OPTIONS= OPTIMIZATION "Enable optimization" off
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC -DPIC
+.endif
+
.if defined(WITH_OPTIMIZATION)
CFLAGS+= -funroll-all-loops -ffast-math -fomit-frame-pointer -D_GNU_SOURCE -D_REENTRANT
.endif