aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms2/Makefile35
-rw-r--r--audio/xmms2/distinfo6
-rw-r--r--audio/xmms2/files/patch-SConstruct13
-rw-r--r--audio/xmms2/files/patch-src_plugins_faad_Plugin8
-rw-r--r--audio/xmms2/files/patch-src_xmms_Program18
-rw-r--r--audio/xmms2/pkg-plist6
6 files changed, 59 insertions, 27 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 95938e300340..5e1871e56fba 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME?= xmms2
-PORTVERSION= 0.2.d.6
-PORTREVISION= 1
+PORTVERSION= 0.2.d.7
CATEGORIES?= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-0.2DrFeelgood
+DISTNAME= ${PORTNAME}-0.2DrGonzo
MAINTAINER= alexbl@FreeBSD.org
COMMENT?= Rewrite of xmms as a client/server system (developer release)
@@ -21,12 +20,9 @@ LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
vorbis.3:${PORTSDIR}/audio/libvorbis
.endif
-WRKSRC= ${WRKDIR}/${DISTNAME}
-
-USE_PYTHON_BUILD= yes
USE_BZIP2= yes
USE_SCONS= yes
-SCONS_ARGS= INSTALLDIR=${DESTDIR} EXCLUDE="${EXCLUDE}"
+SCONS_ARGS= INSTALLDIR=${DESTDIR} SHAREDIR=${DATADIR} EXCLUDE="${EXCLUDE}"
.if !defined(XMMS2_SLAVE)
USE_GNOME= glib20
@@ -37,7 +33,7 @@ USE_LDCONFIG= yes
.if !defined(XMMS2_SLAVE)
MAN1= xmms2.1 xmms2-et.1
-MAN8= xmms2d.8
+MAN8= xmms2d.8 xmms2-launcher.8 xmms2-mdns-avahi.8
MANCOMPRESSED= yes
OPTIONS= FAAD "Support to playback AAC files" on \
@@ -46,15 +42,17 @@ OPTIONS= FAAD "Support to playback AAC files" on \
MUSEPACK "Support to playback MPC files" off \
SID "Support to playback SID files" off \
WMA "Support to playback WMA files" off \
+ APE "Support to playback Monkey's Audio files" off \
CURL "Support to playback files via HTTP" on \
GNOMEVFS "Support to playback files via GnomeVFS" off \
MMS "Support to playback streams via MMS" off \
SAMBA "Support to playback files via SMB" off \
+ DAAP "Support to playback files via DAAP" on \
FAM "Support to update Media Library on file change" off \
MDNS_AVAHI "Support to announce XMMS2d via mDNS (Avahi)" off \
- MDNS_APPLE "Support to announce XMMS2d via mDNS (Apple)" on #\
+ MDNS_APPLE "Support to announce XMMS2d via mDNS (Apple)" on \
+ JACK "Support to output via the Jack output server" off #\
# SDL "Support for visualization" on \
-# JACK "Support to output via the Jack output server" off
.endif
.include <bsd.port.pre.mk>
@@ -114,6 +112,14 @@ EXCLUDE+= wma
PLIST_SUB+= WMA="@comment "
.endif
+.if defined(WITH_APE)
+LIB_DEPENDS+= mac.2:${PORTSDIR}/audio/mac
+PLIST_SUB+= MAC=""
+.else
+EXCLUDE+= mac
+PLIST_SUB+= MAC="@comment "
+.endif
+
.if !defined(WITHOUT_SDL) && defined(UNDEFINED)
IGNORE= visualization has not been updated to the Transforms API
USE_SDL= sdl ttf
@@ -157,6 +163,13 @@ EXCLUDE+= samba
PLIST_SUB+= SAMBA="@comment "
.endif
+.if !defined(WITHOUT_DAAP)
+PLIST_SUB+= DAAP=""
+.else
+EXCLUDE+= daap
+PLIST_SUB+= DAAP="@comment "
+.endif
+
.if defined(WITH_GNOMEVFS)
USE_GNOME+= gnomevfs2
PLIST_SUB+= GNOMEVFS=""
@@ -195,7 +208,7 @@ LIB_DEPENDS+= dns_sd:${PORTSDIR}/net/mDNSResponder
PLIST_SUB+= MDNS_APPLE=""
.else
EXCLUDE+= dns_sd
-PLIST_SUB+= MDNS_APPLE="@comment "
+PLIST_SUB+= MDNS_APPLE="@comment "
.endif
.endif
diff --git a/audio/xmms2/distinfo b/audio/xmms2/distinfo
index a7339753c886..a5ae45465600 100644
--- a/audio/xmms2/distinfo
+++ b/audio/xmms2/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmms2-0.2DrFeelgood.tar.bz2) = 46dc92bb78bf16d6cd9a733e6a923a92
-SHA256 (xmms2-0.2DrFeelgood.tar.bz2) = 8154dee69682ddca438e850dd0a83cda69226d147833d45b1451016dfe337162
-SIZE (xmms2-0.2DrFeelgood.tar.bz2) = 1012425
+MD5 (xmms2-0.2DrGonzo.tar.bz2) = 0845dc7ce04d1825c28566b5c36f23b3
+SHA256 (xmms2-0.2DrGonzo.tar.bz2) = 59a069e2a9b00ef81870a616b0b4ae076ccf63598ec79ba2b1820df2b60f870b
+SIZE (xmms2-0.2DrGonzo.tar.bz2) = 1045538
diff --git a/audio/xmms2/files/patch-SConstruct b/audio/xmms2/files/patch-SConstruct
new file mode 100644
index 000000000000..6904c8357ce6
--- /dev/null
+++ b/audio/xmms2/files/patch-SConstruct
@@ -0,0 +1,13 @@
+--- SConstruct.orig Tue Sep 26 21:07:58 2006
++++ SConstruct Tue Sep 26 21:08:16 2006
+@@ -182,8 +182,8 @@
+ base_env.add_manpage(1, 'doc/xmms2.1')
+ base_env.add_manpage(8, 'doc/xmms2d.8')
+ base_env.add_manpage(1, 'doc/xmms2-et.1')
+-base_env.add_manpage(1, 'doc/xmms2-launcher.8')
+-base_env.add_manpage(1, 'doc/xmms2-mdns-avahi.8')
++base_env.add_manpage(8, 'doc/xmms2-launcher.8')
++base_env.add_manpage(8, 'doc/xmms2-mdns-avahi.8')
+
+ #### Generate pc files.
+
diff --git a/audio/xmms2/files/patch-src_plugins_faad_Plugin b/audio/xmms2/files/patch-src_plugins_faad_Plugin
index e49dc3f92cbc..8c20d2479bec 100644
--- a/audio/xmms2/files/patch-src_plugins_faad_Plugin
+++ b/audio/xmms2/files/patch-src_plugins_faad_Plugin
@@ -1,5 +1,5 @@
---- src/plugins/faad/Plugin.orig Sat Jul 15 22:18:48 2006
-+++ src/plugins/faad/Plugin Sat Jul 15 22:19:02 2006
+--- src/plugins/faad/Plugin.orig Tue Sep 26 20:35:50 2006
++++ src/plugins/faad/Plugin Tue Sep 26 20:36:04 2006
@@ -2,13 +2,7 @@
source=['faad.c', 'mp4ff/drms.c', 'mp4ff/mp4atom.c', 'mp4ff/mp4ff.c', 'mp4ff/mp4meta.c', 'mp4ff/mp4sample.c', 'mp4ff/mp4tagupdate.c', 'mp4ff/mp4util.c']
@@ -11,7 +11,7 @@
- except ConfigError:
- raise ConfigError("Could not find libfaad")
-
-+ env.Append (LIBS = ['faad'])
- env.Append (CCFLAGS = '-DUSE_TAGGING')
++ env.Append(LIBS=['faad'])
+ env.Append(CPPDEFINES=['USE_TAGGING'])
# to use iTunes DRM change this to true
diff --git a/audio/xmms2/files/patch-src_xmms_Program b/audio/xmms2/files/patch-src_xmms_Program
index 1479b160b6a2..51b657b348aa 100644
--- a/audio/xmms2/files/patch-src_xmms_Program
+++ b/audio/xmms2/files/patch-src_xmms_Program
@@ -1,9 +1,9 @@
---- src/xmms/Program.orig Thu Jul 6 15:35:55 2006
-+++ src/xmms/Program Thu Jul 6 17:36:50 2006
-@@ -29,10 +29,10 @@
- env.Append(LIBS=['xmmsipc'])
- env.Append(LIBS=["xmmssocket"])
- env.Append(CPPPATH=["#src/includepriv"])
+--- src/xmms/Program.orig Tue Sep 26 20:51:07 2006
++++ src/xmms/Program Tue Sep 26 20:51:39 2006
+@@ -26,10 +26,10 @@
+
+ def config(env):
+ pluginenv = env.Copy()
- env.pkgconfig("glib-2.0 >= 2.6.0", fail=True)
- env.pkgconfig("gmodule-2.0", fail=True)
- env.pkgconfig("gthread-2.0", fail=True)
@@ -12,6 +12,6 @@
+ env.pkgconfig("gmodule-2.0")
+ env.pkgconfig("gthread-2.0")
+ env.pkgconfig("sqlite3")
-
- if env.platform != 'win32':
- env.checklib("m", "sin", fail=True)
+ env.Prepend(LIBPATH=["src/lib/xmmsipc"])
+ env.Prepend(LIBPATH=["src/lib/xmmssocket"])
+ env.Append(LIBS=['xmmsipc'])
diff --git a/audio/xmms2/pkg-plist b/audio/xmms2/pkg-plist
index 08dba045c3ef..c39d05d2e9ec 100644
--- a/audio/xmms2/pkg-plist
+++ b/audio/xmms2/pkg-plist
@@ -6,6 +6,7 @@ bin/xmms2-launcher
%%MDNS_AVAHI%%bin/xmms2-mdns-avahi
%%MDNS_APPLE%%bin/xmms2-mdns-dnssd
bin/xmms2d
+include/xmms2/xmms/xmms_bindata.h
include/xmms2/xmms/xmms_config.h
include/xmms2/xmms/xmms_defs.h
include/xmms2/xmms/xmms_effect.h
@@ -20,6 +21,7 @@ include/xmms2/xmms/xmms_plsplugins.h
include/xmms2/xmms/xmms_plugin.h
include/xmms2/xmms/xmms_sample.h
include/xmms2/xmms/xmms_streamtype.h
+include/xmms2/xmms/xmms_strfunc.h
include/xmms2/xmms/xmms_xformplugin.h
include/xmms2/xmmsc/xmmsc_asyncns.h
include/xmms2/xmmsc/xmmsc_errorcodes.h
@@ -33,6 +35,7 @@ include/xmms2/xmmsc/xmmsc_stdint.h
include/xmms2/xmmsc/xmmsc_stringport.h
include/xmms2/xmmsc/xmmsc_unistd.h
include/xmms2/xmmsc/xmmsc_util.h
+include/xmms2/xmmsclient/xmmsclient++/bindata.h
include/xmms2/xmmsclient/xmmsclient++/client.h
include/xmms2/xmmsclient/xmmsclient++/config.h
include/xmms2/xmmsclient/xmmsclient++/dict.h
@@ -47,6 +50,7 @@ include/xmms2/xmmsclient/xmmsclient++/playlist.h
include/xmms2/xmmsclient/xmmsclient++/signal.h
include/xmms2/xmmsclient/xmmsclient++/stats.h
include/xmms2/xmmsclient/xmmsclient++/typedefs.h
+include/xmms2/xmmsclient/xmmsclient++/xform.h
include/xmms2/xmmsclient/xmmsclient++-glib.h
include/xmms2/xmmsclient/xmmsclient++.h
include/xmms2/xmmsclient/xmmsclient-cf.h
@@ -61,6 +65,7 @@ lib/libxmmsclient.so
%%CURL%%lib/xmms2/libxmms_curl_http.so
lib/xmms2/libxmms_diskwrite.so
lib/xmms2/libxmms_equalizer.so
+%%DAAP%%lib/xmms2/libxmms_daap.so
%%FAAD%%lib/xmms2/libxmms_faad.so
%%FLAC%%lib/xmms2/libxmms_flac.so
lib/xmms2/libxmms_file.so
@@ -69,6 +74,7 @@ lib/xmms2/libxmms_icymetaint.so
lib/xmms2/libxmms_id3v2.so
%%JACK%%lib/xmms2/libxmms_jack.so
lib/xmms2/libxmms_mad.so
+%%MAC%%lib/xmms2/libxmms_mac.so
%%MMS%%lib/xmms2/libxmms_mms.so
%%MODPLUG%%lib/xmms2/libxmms_modplug.so
%%MUSEPACK%%lib/xmms2/libxmms_musepack.so