aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libfishsound/Makefile39
-rw-r--r--audio/libfishsound/distinfo3
-rw-r--r--audio/libfishsound/pkg-descr16
-rw-r--r--audio/libfishsound/pkg-plist12
5 files changed, 71 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index be8f1c56c311..5006d6477501 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -359,6 +359,7 @@
SUBDIR += libconvolve
SUBDIR += libdiscid
SUBDIR += libdssialsacompat
+ SUBDIR += libfishsound
SUBDIR += libgig
SUBDIR += libgme
SUBDIR += libgpod
diff --git a/audio/libfishsound/Makefile b/audio/libfishsound/Makefile
new file mode 100644
index 000000000000..a0e5393037f5
--- /dev/null
+++ b/audio/libfishsound/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: libfishsound
+# Date created: 2010-05-28
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libfishsound
+PORTVERSION= 1.0.0
+CATEGORIES= audio
+MASTER_SITES= http://downloads.xiph.org/releases/libfishsound/ \
+ http://sunpoet.net/distfiles/
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= A programing interface to decode/encode audio data
+
+LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac \
+ speex:${PORTSDIR}/audio/speex \
+ vorbis:${PORTSDIR}/audio/libvorbis
+
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack pkgconfig
+USE_LDCONFIG= yes
+
+OPTIONS= DOXYGEN "Doxygen is required for generating documents" off
+
+.include <bsd.port.options.mk>
+
+.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
+PORTDOCS= *
+.endif
+
+post-patch:
+.if defined(NOPORTDOCS) || !defined(WITH_DOXYGEN)
+ @${REINPLACE_CMD} -e '/^SUBDIRS = / s| doc||' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/libfishsound/distinfo b/audio/libfishsound/distinfo
new file mode 100644
index 000000000000..c78900936a6c
--- /dev/null
+++ b/audio/libfishsound/distinfo
@@ -0,0 +1,3 @@
+MD5 (libfishsound-1.0.0.tar.gz) = 02c5c7b361a35c9da3cf311d68800dab
+SHA256 (libfishsound-1.0.0.tar.gz) = 2e0b57ce2fecc9375eef72938ed08ac8c8f6c5238e1cae24458f0b0e8dade7c7
+SIZE (libfishsound-1.0.0.tar.gz) = 444980
diff --git a/audio/libfishsound/pkg-descr b/audio/libfishsound/pkg-descr
new file mode 100644
index 000000000000..88fc2b87a3b6
--- /dev/null
+++ b/audio/libfishsound/pkg-descr
@@ -0,0 +1,16 @@
+libfishsound provides a simple programming interface for decoding and encoding
+audio data using the Xiph.org codecs (FLAC, Speex and Vorbis).
+
+libfishsound by itself is designed to handle raw codec streams from a lower
+level layer such as UDP datagrams. When these codecs are used in files, they
+are commonly encapsulated in Ogg to produce Ogg FLAC, Speex and Ogg Vorbis
+files.
+
+libfishsound is a wrapper around the existing codec libraries and provides a
+consistent, higher-level programming interface. It has been designed for use in
+a wide variety of applications; it has no direct dependencies on Ogg
+encapsulation, though it is most commonly used in conjunction with liboggz to
+decode or encode FLAC, Speex or Vorbis audio tracks in Ogg files, including Ogg
+Theora and Annodex.
+
+WWW: http://www.xiph.org/fishsound/
diff --git a/audio/libfishsound/pkg-plist b/audio/libfishsound/pkg-plist
new file mode 100644
index 000000000000..492b1cecd1a3
--- /dev/null
+++ b/audio/libfishsound/pkg-plist
@@ -0,0 +1,12 @@
+include/fishsound/comments.h
+include/fishsound/constants.h
+include/fishsound/decode.h
+include/fishsound/deprecated.h
+include/fishsound/encode.h
+include/fishsound/fishsound.h
+lib/libfishsound.a
+lib/libfishsound.la
+lib/libfishsound.so
+lib/libfishsound.so.4
+libdata/pkgconfig/fishsound.pc
+@dirrm include/fishsound