aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/yell/Makefile21
-rw-r--r--audio/yell/pkg-descr10
-rw-r--r--audio/yell/pkg-message6
3 files changed, 14 insertions, 23 deletions
diff --git a/audio/yell/Makefile b/audio/yell/Makefile
index db8b26c97ea8..50325b295e8e 100644
--- a/audio/yell/Makefile
+++ b/audio/yell/Makefile
@@ -12,18 +12,20 @@ MASTER_SITES= http://critical.ch/distfiles/ \
http://energy.critical.ch/distfiles/
MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= A command line speaker bell using machine/speaker.h
+COMMENT= A command line pc speaker bell
PLIST_FILES= bin/yell
ONLY_FOR_ARCHS= i386
-pre-everything::
-.if !defined(WITH_SUID)
- @${ECHO_CMD} ""
- @${ECHO_CMD} "You can define WITH_SUID if you want yell to be installed with"
- @${ECHO_CMD} "the sticky bit (mode 4110)"
- @${ECHO_CMD} ""
+OPTIONS= SUID "Set the setuid bit on the yell program" off
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} >= 601000
+ @${REINPLACE_CMD} -e 's|machine/speaker.h|dev/speaker/speaker.h|' \
+ ${WRKSRC}/${PORTNAME}.c
.endif
do-build:
@@ -36,7 +38,4 @@ do-install:
${INSTALL_PROGRAM} -m 0100 ${WRKSRC}/${PORTNAME} ${TARGETDIR}/bin
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/yell/pkg-descr b/audio/yell/pkg-descr
index fe7aa66e7bcf..6af8691ce91f 100644
--- a/audio/yell/pkg-descr
+++ b/audio/yell/pkg-descr
@@ -1,9 +1,7 @@
-Yell is a little command line utility playing a short tune on your
-speaker device. I mainly use it to yell the "sysop" on a remote
-machine. It could also be used as a notification for finished tasks
-(eg. make buildworld && yell).
+Yell is a little command line utility playing a short tune on your speaker
+device. I mainly use it to yell the "sysop" on a remote machine. It could also
+be used as a notification for finished tasks (eg. make buildworld && yell).
WWW: http://www.critical.ch/yell
-- ehaupt
-ehaupt@critical.ch
+- ehaupt ehaupt@critical.ch
diff --git a/audio/yell/pkg-message b/audio/yell/pkg-message
deleted file mode 100644
index 0adf51c5868e..000000000000
--- a/audio/yell/pkg-message
+++ /dev/null
@@ -1,6 +0,0 @@
-*******************************************************************************
-yell is now installed. Make sure that speaker.ko is loaded on your system.
-Under FreeBSD 5.x you can put speaker_load="YES" in your /boot/loader.conf.
-You can manually load speaker.ko by typing "kldload speaker" or recompile your
-kernel with "device speaker".
-*******************************************************************************