aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/aacplusenc/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/audio/aacplusenc/Makefile b/audio/aacplusenc/Makefile
index da69444ed122..7728a2aed59b 100644
--- a/audio/aacplusenc/Makefile
+++ b/audio/aacplusenc/Makefile
@@ -13,6 +13,10 @@ COMMENT= AacPlus v2 command-line encoder
USES= gmake
+OPTIONS_DEFINE= FFTW3
+OPTIONS_DEFAULT= FFTW3
+FFTW3_DESC= Use FFTW3 library for performance
+
RESTRICTED= unclear legal status, probably need licenses from 3GPP, Via Licensing and Coding Technologies
CONFLICTS= libaacplus-[0-9]*
@@ -20,13 +24,10 @@ CONFLICTS= libaacplus-[0-9]*
PLIST_FILES= bin/aacplusenc
MAKE_ARGS+= INSTDIR=${STAGEDIR}${PREFIX}
-.if defined(WITHOUT_FFTW3)
-MAKE_ARGS+= NOFFTW3=1
-.else
-LIB_DEPENDS+= libfftw3f.so:${PORTSDIR}/math/fftw3-float \
- libfftw3.so:${PORTSDIR}/math/fftw3
-CFLAGS+= -I${LOCALBASE}/include
-.endif
+FFTW3_MAKE_ARGS_OFF= NOFFTW3=1
+FFTW3_LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float \
+ libfftw3.so:${PORTSDIR}/math/fftw3
+FFTW3_CFLAGS= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/${PORTNAME}