aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/vorbis-tools/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index f268d71b5bc9..a30baa28de29 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -11,6 +11,9 @@ MASTER_SITES= http://downloads.xiph.org/releases/vorbis/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Play, encode, and manage Ogg Vorbis files
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao \
libcurl.so:${PORTSDIR}/ftp/curl \
libFLAC.so:${PORTSDIR}/audio/flac \
@@ -18,7 +21,8 @@ LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao \
libspeex.so:${PORTSDIR}/audio/speex \
libvorbis.so:${PORTSDIR}/audio/libvorbis
-USES= iconv pkgconfig
+USES= cpe iconv pkgconfig
+CPE_VENDOR= xiph
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_LIBS="-lpthread"
CPPFLAGS+= -I${LOCALBASE}/include