aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-sapplug/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index b3768e18d686..d160a24df4cc 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -29,7 +29,9 @@ OPTIONS_DEFINE= OPTIMIZED_CFLAGS
.include <bsd.port.options.mk>
-.if ${CXX:T} != "clang++"
+_CLANG!= clang --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+
+.if ${CXX:T} != "clang++" && !defined(_CLANG)
CXXFLAGS+= --no-exceptions
.endif