aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/gstreamer-plugins-moodbar/Makefile2
-rw-r--r--audio/gstreamer-plugins-moodbar/files/patch-main.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/audio/gstreamer-plugins-moodbar/Makefile b/audio/gstreamer-plugins-moodbar/Makefile
index 30ebc496beb2..1065a8d0e24e 100644
--- a/audio/gstreamer-plugins-moodbar/Makefile
+++ b/audio/gstreamer-plugins-moodbar/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gstreamer-plugins-moodbar
PORTVERSION= 0.1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://pwsp.net/~qbob/ \
http://redundancy.redundancy.org/mirror/
diff --git a/audio/gstreamer-plugins-moodbar/files/patch-main.c b/audio/gstreamer-plugins-moodbar/files/patch-main.c
new file mode 100644
index 000000000000..945b9a961348
--- /dev/null
+++ b/audio/gstreamer-plugins-moodbar/files/patch-main.c
@@ -0,0 +1,20 @@
+diff -crB analyzer/main.c analyzer_patched/main.c
+*** analyzer/main.c 2006-10-12 07:43:30.000000000 +0200
+--- analyzer_patched/main.c 2010-02-15 20:24:57.000000000 +0100
+***************
+*** 261,267 ****
+ };
+ GOptionContext *ctx;
+ GError *err = NULL;
+!
+ ctx = g_option_context_new ("[INFILE] - Run moodbar analyzer");
+ g_option_context_add_group (ctx, gst_init_get_option_group ());
+ g_option_context_add_main_entries (ctx, entries, NULL);
+--- 261,267 ----
+ };
+ GOptionContext *ctx;
+ GError *err = NULL;
+! g_thread_init(NULL);
+ ctx = g_option_context_new ("[INFILE] - Run moodbar analyzer");
+ g_option_context_add_group (ctx, gst_init_get_option_group ());
+ g_option_context_add_main_entries (ctx, entries, NULL);