aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/libid3tag/Makefile3
-rw-r--r--audio/mp3asm/Makefile4
-rw-r--r--audio/mp3gain/Makefile4
-rw-r--r--audio/rsynth/Makefile3
4 files changed, 8 insertions, 6 deletions
diff --git a/audio/libid3tag/Makefile b/audio/libid3tag/Makefile
index 0193db93d548..11e17c4be67b 100644
--- a/audio/libid3tag/Makefile
+++ b/audio/libid3tag/Makefile
@@ -13,9 +13,10 @@ COMMENT= ID3 tags library (part of MAD project)
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+NO_STAGE= yes
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-NO_STAGE= yes
USES= pkgconfig
post-patch:
diff --git a/audio/mp3asm/Makefile b/audio/mp3asm/Makefile
index a83b6cb10284..9deec2afe7df 100644
--- a/audio/mp3asm/Makefile
+++ b/audio/mp3asm/Makefile
@@ -13,12 +13,12 @@ COMMENT= MP3 frame level editor
LICENSE= GPLv2
-WRKSRC= ${WRKDIR}/${PORTNAME}-0.1
-
NO_STAGE= yes
+
USES= gmake
USE_BZIP2= yes
GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.1
post-extract:
@${RM} ${WRKSRC}/config.cache
diff --git a/audio/mp3gain/Makefile b/audio/mp3gain/Makefile
index 798966d52966..0165723c340d 100644
--- a/audio/mp3gain/Makefile
+++ b/audio/mp3gain/Makefile
@@ -12,12 +12,12 @@ COMMENT= A tool to normalize the gain of MP3 files
LICENSE= LGPL21
-PLIST_FILES= bin/mp3gain
NO_STAGE= yes
+
USE_ZIP= yes
USE_DOS2UNIX= yes
-
NO_WRKSUBDIR= yes
+PLIST_FILES= bin/mp3gain
post-patch:
@${CP} ${FILESDIR}/Makefile.main ${WRKSRC}/Makefile
diff --git a/audio/rsynth/Makefile b/audio/rsynth/Makefile
index f58fa281e580..dc1346666e6c 100644
--- a/audio/rsynth/Makefile
+++ b/audio/rsynth/Makefile
@@ -13,9 +13,10 @@ COMMENT= Speech synthesizer
LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm \
audio:${PORTSDIR}/audio/nas
+NO_STAGE= yes
+
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
-NO_STAGE= yes
pre-configure:
@${CP} ${FILESDIR}/freebsdplay.c ${WRKSRC}/config/freebsdplay.c