aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/fpc-openal/Makefile23
-rw-r--r--audio/fpc-openal/pkg-plist9
3 files changed, 33 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index ec4399b2ddee..93aa2c17e200 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -200,6 +200,7 @@
SUBDIR += fpc-mad
SUBDIR += fpc-modplug
SUBDIR += fpc-oggvorbis
+ SUBDIR += fpc-openal
SUBDIR += freealut
SUBDIR += freedesktop-sound-theme
SUBDIR += freepats
diff --git a/audio/fpc-openal/Makefile b/audio/fpc-openal/Makefile
new file mode 100644
index 000000000000..7ee97f07c9a0
--- /dev/null
+++ b/audio/fpc-openal/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-openal
+# Date created: 2010-04-22
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= audio lang
+PKGNAMESUFFIX= -openal
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to openal library
+
+USE_FPC= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= OPENAL "Install openal library" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/audio/fpc-openal/pkg-plist b/audio/fpc-openal/pkg-plist
new file mode 100644
index 000000000000..3ddd33e3f69c
--- /dev/null
+++ b/audio/fpc-openal/pkg-plist
@@ -0,0 +1,9 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openal/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openal/openal.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openal/openal.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openal/libpopenal.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openal
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc