aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/netpipe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/netpipe/Makefile')
-rw-r--r--benchmarks/netpipe/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/benchmarks/netpipe/Makefile b/benchmarks/netpipe/Makefile
index 1d1de15a40a0..ab3fba70eaa8 100644
--- a/benchmarks/netpipe/Makefile
+++ b/benchmarks/netpipe/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= NetPIPE
-PORTVERSION= 3.6
+PORTVERSION= 3.6.2
CATEGORIES= benchmarks net
MASTER_SITES= http://www.scl.ameslab.gov/Projects/Netpipe/code/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -19,13 +19,19 @@ MAKEFILE= makefile
# The default port builds and installs only the TCP version of
# netpipe(1). The sources support many other variants.
-ALL_TARGET= tcp
+ALL_TARGET= tcp tcp6
+.if !defined(NOPORTDOCS)
+MAN1= netpipe.1
+MANCOMPRESSED= no
DOCS= README netpipe_paper.ps
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/NPtcp ${PREFIX}/bin/NPtcp
+ ${INSTALL_PROGRAM} ${WRKSRC}/NPtcp6 ${PREFIX}/bin/NPtcp6
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/netpipe
+ ${INSTALL_MAN} ${WRKSRC}/dox/netpipe.1 ${PREFIX}/man/man1
.for doc in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/dox/${doc} ${PREFIX}/share/doc/netpipe/${doc}
.endfor