aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/pybench/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/pybench/Makefile')
-rw-r--r--benchmarks/pybench/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/benchmarks/pybench/Makefile b/benchmarks/pybench/Makefile
new file mode 100644
index 000000000000..2f6de786ffae
--- /dev/null
+++ b/benchmarks/pybench/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pybench
+# Date created: 29 March 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pybench
+PORTVERSION= 0.8
+CATEGORIES= benchmarks python
+MASTER_SITES= http://www.lemburg.com/files/python/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_ZIP= yes
+USE_PYTHON= yes
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/pybench
+ @(cd ${WRKSRC} && ${TAR} --exclude README -c -f - .) \
+ | (cd ${PREFIX}/share/pybench && ${TAR} --unlink -x -f -)
+ @printf "#!/bin/sh\n${PYTHON_CMD} ${PREFIX}/share/pybench/pybench.py\n" \
+ > ${WRKDIR}/pybench.sh
+ @${MKDIR} ${PREFIX}/share/doc/pybench
+ @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/pybench
+ @${INSTALL_SCRIPT} ${WRKDIR}/pybench.sh ${PREFIX}/bin/pybench
+
+.include <bsd.port.mk>