aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/randomio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/randomio/Makefile')
-rw-r--r--benchmarks/randomio/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/benchmarks/randomio/Makefile b/benchmarks/randomio/Makefile
new file mode 100644
index 000000000000..ae763adaccc8
--- /dev/null
+++ b/benchmarks/randomio/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: randomio
+# Date created: 20 Aug 2010
+# Whom: Sergey Kandaurov <pluknet@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= randomio
+PORTVERSION= 1.4
+CATEGORIES= benchmarks
+MASTER_SITES= http://www.arctic.org/~dean/randomio/
+
+MAINTAINER= pluknet@gmail.com
+COMMENT= A multithreaded disk i/o microbenchmark
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>