aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/slowloris/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/benchmarks/slowloris/Makefile b/benchmarks/slowloris/Makefile
index 77747a292cdf..306a39b85ecd 100644
--- a/benchmarks/slowloris/Makefile
+++ b/benchmarks/slowloris/Makefile
@@ -20,13 +20,15 @@ PLIST_FILES= bin/slowloris
NO_STAGE= yes
.include <bsd.port.pre.mk>
-PERL_THREADS= no
+PERL_THREADS= yes
.if exists(${PERL})
PERL_THREADS!= ${PERL} -V::usethreads
.if ${PERL_THREADS} == "'define';"
RUN_DEPENDS+= p5-threads-shared>=0:${PORTSDIR}/devel/p5-threads-shared
PERL_THREADS= yes
+.else
+PERL_THREADS= no
.endif
.endif