aboutsummaryrefslogtreecommitdiffstats
path: root/biology/avida/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/avida/Makefile')
-rw-r--r--biology/avida/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/biology/avida/Makefile b/biology/avida/Makefile
index 825a3dc3b317..430d244e5836 100644
--- a/biology/avida/Makefile
+++ b/biology/avida/Makefile
@@ -39,6 +39,12 @@ DIR2FIX= source/main/functional_testsuites/default.md5sum/genesis \
source/qt-viewer/setup_genesis.cc source/support/genesis \
source/support/genesis.4stack source/main/config.cc source/defs.hh
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-configure:
.for src in ${DIR2FIX}
@${REINPLACE_CMD} -e "s|../work/|${DATADIR}/|" ${WRKSRC}/${src}
@@ -53,4 +59,4 @@ post-install:
${INSTALL_PROGRAM} ${WRKSRC}/work/qt-viewer ${PREFIX}/bin
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>