aboutsummaryrefslogtreecommitdiffstats
path: root/biology/crux/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/crux/Makefile')
-rw-r--r--biology/crux/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/biology/crux/Makefile b/biology/crux/Makefile
index b303a7f992bb..b6e7dce08b3e 100644
--- a/biology/crux/Makefile
+++ b/biology/crux/Makefile
@@ -10,22 +10,20 @@ MASTER_SITES= http://www.canonware.com/download/Crux/
MAINTAINER= jasone@FreeBSD.org
COMMENT= Software toolkit for phylogenetic inference
+USES= fortran gmake
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-python=${PYTHON_CMD} --disable-mpi
USE_CSTD= gnu99
-USE_GMAKE= yes
USE_PYTHON= yes
OPTIONS_DEFINE= SYS_LINALG
SYS_LINALG_DESC= Enable system ATLAS/LAPACK
NO_STAGE= yes
-.include <bsd.port.pre.mk>
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_FORTRAN= yes
.include <bsd.port.options.mk>
@@ -43,4 +41,4 @@ BROKEN= Does not build on powerpc-9: error in pthreads
post-install:
@${PREFIX}/bin/crux -b -q /dev/null
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>