aboutsummaryrefslogtreecommitdiffstats
path: root/biology/emboss/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/emboss/Makefile')
-rw-r--r--biology/emboss/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/biology/emboss/Makefile b/biology/emboss/Makefile
index 7264cc695ce4..e246f10d8e31 100644
--- a/biology/emboss/Makefile
+++ b/biology/emboss/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= emboss
-PORTVERSION= 1.1.0
+PORTVERSION= 1.4.0
CATEGORIES= biology
MASTER_SITES= ftp://ftp.uk.embnet.org/pub/EMBOSS/
DISTNAME= EMBOSS-${PORTVERSION}
@@ -22,6 +22,15 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/gd" \
LIBS="-L${LOCALBASE}/lib"
+DOC_DIRS= doc/manuals doc/tutorials doc/programs/text doc/programs/html
+
+post-patch:
+.for DIR in ${DOC_DIRS}
+ @ ${PERL} -pi.orig -e \
+ "s#share/\\$$\(PACKAGE\)/doc#share/doc/\\$$\(PACKAGE\)#" \
+ ${WRKSRC}/${DIR}/Makefile.in
+.endfor
+
post-install:
@ ${INSTALL_DATA} ${WRKSRC}/emboss/acd/emboss.default \
${PREFIX}/etc/emboss.default.sample
@@ -29,13 +38,4 @@ post-install:
@ ${CAT} ${PKGMESSAGE}
.endif
-DOC_DIRS= doc/manuals doc/tutorials doc/programs/text doc/programs/html
-
-post-patch:
-.for DIR in ${DOC_DIRS}
- @perl -pi.orig -e \
- "s#share/\\$$\(PACKAGE\)/doc#share/doc/\\$$\(PACKAGE\)#" \
- ${WRKSRC}/${DIR}/Makefile.in
-.endfor
-
.include <bsd.port.mk>