aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/seqan-apps/Makefile46
-rw-r--r--biology/seqan-apps/distinfo2
-rw-r--r--biology/seqan-apps/pkg-descr11
-rw-r--r--biology/seqan-apps/pkg-plist160
5 files changed, 220 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 97cdac5ece8c..4a21bff385f4 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -90,6 +90,7 @@
SUBDIR += samtools
SUBDIR += seaview
SUBDIR += seqan
+ SUBDIR += seqan-apps
SUBDIR += seqio
SUBDIR += seqtools
SUBDIR += sim4
diff --git a/biology/seqan-apps/Makefile b/biology/seqan-apps/Makefile
new file mode 100644
index 000000000000..e5ed8f45e71c
--- /dev/null
+++ b/biology/seqan-apps/Makefile
@@ -0,0 +1,46 @@
+# Created by: Hannes Hauswedell <h2+fbsdports@fsfe.org>
+# $FreeBSD$
+
+PORTNAME= seqan-apps
+PORTVERSION= 2.1.1
+DISTVERSIONPREFIX= seqan-v
+CATEGORIES= biology
+
+MAINTAINER= h2+fbsdports@fsfe.org
+COMMENT= Official Bioinformatic applications based on the SeqAn library
+
+LICENSE= BSD3CLAUSE LGPL3 GPLv3
+LICENSE_COMB= multi
+
+BUILD_DEPENDS= boost-libs>0:devel/boost-libs
+
+USE_GITHUB= yes
+GH_ACCOUNT= seqan
+GH_PROJECT= seqan
+
+# once #199603 is resolved, do the following instead of USE_GCC
+# USES= cmake:outsource compiler:openmp,c++14-lang
+USES= cmake:outsource
+CMAKE_ARGS= -DSEQAN_BUILD_SYSTEM="SEQAN_RELEASE_APPS"
+
+USE_GCC= 4.9+
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+post-patch:
+ # missing C99 functions in FreeBSD's math.h, use C++ instead
+ @${REINPLACE_CMD} -e 's|expl(|std::exp(|g' ${WRKSRC}/apps/snp_store/snp_store.h
+ @${REINPLACE_CMD} -e 's|logl(|std::log(|g' ${WRKSRC}/apps/snp_store/snp_store.h
+ # the other way around (use math.h instead of cmath)
+ @${REINPLACE_CMD} -e 's|std::round|round|g' ${WRKSRC}/apps/yara/mapper_writer.h
+ @${REINPLACE_CMD} -e 's|std::erfc|erfc|g' ${WRKSRC}/apps/yara/bits_matches.h
+.endif
+
+.if ${ARCH} == "i386"
+PLIST_SUB+= RM_I386="@comment "
+.else
+PLIST_SUB+= RM_I386=""
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/biology/seqan-apps/distinfo b/biology/seqan-apps/distinfo
new file mode 100644
index 000000000000..8d2727d8717b
--- /dev/null
+++ b/biology/seqan-apps/distinfo
@@ -0,0 +1,2 @@
+SHA256 (seqan-seqan-seqan-v2.1.1_GH0.tar.gz) = df083d5939d7e73fd00bbc6bb291ac7ea7b8d446cf89a9758fdffdc0eca9ec1c
+SIZE (seqan-seqan-seqan-v2.1.1_GH0.tar.gz) = 110874831
diff --git a/biology/seqan-apps/pkg-descr b/biology/seqan-apps/pkg-descr
new file mode 100644
index 000000000000..fbcdf62521e2
--- /dev/null
+++ b/biology/seqan-apps/pkg-descr
@@ -0,0 +1,11 @@
+SeqAn is an open source C++ library of efficient algorithms
+and data structures for the analysis of sequences with the
+focus on biological data.
+
+This port contains applications built on SeqAn and developed
+within the SeqAn project. Among them are famous read mappers
+like RazerS and Yara, as well as many other tools. Some
+applications are packaged seperately and the library
+can be found at biology/seqan.
+
+WWW: http://www.seqan.de/
diff --git a/biology/seqan-apps/pkg-plist b/biology/seqan-apps/pkg-plist
new file mode 100644
index 000000000000..747936672f94
--- /dev/null
+++ b/biology/seqan-apps/pkg-plist
@@ -0,0 +1,160 @@
+bin/alf
+bin/bam2roi
+bin/bed_sort.sh
+bin/bisar
+bin/casbar
+%%RM_I386%%bin/compute_gain
+bin/dfi
+%%RM_I386%%bin/fiona
+bin/four2three
+bin/fx_bam_coverage
+bin/gff_sort.sh
+bin/gustaf
+bin/gustaf_mate_joining
+bin/insegt
+bin/mason_frag_sequencing
+bin/mason_genome
+bin/mason_materializer
+bin/mason_methylation
+bin/mason_simulator
+bin/mason_splicing
+bin/mason_variator
+bin/micro_razers
+bin/pair_align
+bin/param_chooser
+bin/plot.awk
+bin/ps2pswLinks.gawk
+bin/rabema_build_gold_standard
+bin/rabema_evaluate
+bin/rabema_prepare_sam
+bin/razers
+bin/razers3
+bin/rep_sep
+bin/roi_feature_projection
+bin/roi_plot_9.sh
+bin/roi_plot_thumbnails
+bin/roi_sort.sh
+bin/s4_join
+bin/s4_search
+bin/sak
+bin/sam2matrix
+bin/samcat
+bin/seqan_tcoffee
+bin/seqcons2
+bin/sgip
+bin/snp_store
+%%RM_I386%%bin/splazers
+bin/stellar
+bin/tree_recon
+bin/yara_indexer
+bin/yara_mapper
+share/doc/alf/LICENSE
+share/doc/alf/README
+share/doc/alf/example/small.fasta
+share/doc/bs_tools/LICENSE
+share/doc/bs_tools/README
+share/doc/dfi/LICENSE
+share/doc/dfi/README
+share/doc/dfi/example/fasta1.fa
+share/doc/dfi/example/fasta2.fa
+%%RM_I386%%share/doc/fiona/LICENSE
+%%RM_I386%%share/doc/fiona/README
+%%RM_I386%%share/doc/fiona/example/reads.fa
+share/doc/fx_tools/LICENSE
+share/doc/fx_tools/README
+share/doc/gustaf/LICENSE
+share/doc/gustaf/README
+share/doc/gustaf/example/adeno.fa
+share/doc/gustaf/example/adeno_modified.fa
+share/doc/gustaf/example/adeno_modified_reads.fa
+share/doc/gustaf/example/stellar.gff
+share/doc/insegt/LICENSE
+share/doc/insegt/README
+share/doc/insegt/example/annoOutput.gff
+share/doc/insegt/example/annotations.gff
+share/doc/insegt/example/readOutput.gff
+share/doc/insegt/example/tupleOutput.gff
+share/doc/mason2/LICENSE
+share/doc/mason2/README
+share/doc/mason2/README.mason_frag_sequencing
+share/doc/mason2/README.mason_genome
+share/doc/mason2/README.mason_materializer
+share/doc/mason2/README.mason_methylation
+share/doc/mason2/README.mason_simulator
+share/doc/mason2/README.mason_splicing
+share/doc/mason2/README.mason_variator
+share/doc/mason2/example/adeno_virus.fa
+share/doc/micro_razers/LICENSE
+share/doc/micro_razers/README
+share/doc/micro_razers/example/genome.fa
+share/doc/micro_razers/example/reads.fa
+share/doc/micro_razers/example/reads.fa.result
+share/doc/ngs_roi/LICENSE
+share/doc/ngs_roi/R/ngsroi_0.1.tar.gz
+share/doc/ngs_roi/R/ngsroi_0.1.zip
+share/doc/ngs_roi/README
+share/doc/ngs_roi/example/dmel.bed
+share/doc/ngs_roi/example/dmel.gtf
+share/doc/ngs_roi/example/example.bam
+share/doc/pair_align/LICENSE
+share/doc/pair_align/README
+share/doc/param_chooser/LICENSE
+share/doc/param_chooser/README
+share/doc/rabema/LICENSE
+share/doc/rabema/README
+share/doc/razers/LICENSE
+share/doc/razers/README
+share/doc/razers/example/genome.fa
+share/doc/razers/example/reads.fa
+share/doc/razers/example/reads2.fa
+share/doc/razers3/LICENSE
+share/doc/razers3/README
+share/doc/razers3/example/genome.fa
+share/doc/razers3/example/reads.fa
+share/doc/razers3/example/reads2.fa
+share/doc/rep_sep/LICENSE
+share/doc/rep_sep/README
+share/doc/sak/LICENSE
+share/doc/sak/README
+share/doc/sak/README.sak.txt
+share/doc/sak/man/sak.1
+share/doc/sam2matrix/LICENSE
+share/doc/sam2matrix/README
+share/doc/samcat/LICENSE
+share/doc/samcat/README
+share/doc/searchjoin/LICENSE
+share/doc/searchjoin/README
+share/doc/seqan_tcoffee/LICENSE
+share/doc/seqan_tcoffee/README
+share/doc/seqan_tcoffee/example/seq.fa
+share/doc/seqcons2/LICENSE
+share/doc/seqcons2/README
+share/doc/sgip/LICENSE
+share/doc/sgip/README
+share/doc/sgip/example/iso_m2D_m196.A01
+share/doc/sgip/example/iso_r01_m200.A00
+share/doc/sgip/example/iso_r01_m200.A01
+share/doc/sgip/example/iso_r01_m200.B00
+share/doc/sgip/example/iso_r01_m200.B01
+share/doc/sgip/example/latin-4
+share/doc/sgip/example/lattice-4
+share/doc/sgip/example/sts-7
+share/doc/snp_store/LICENSE
+share/doc/snp_store/README
+share/doc/snp_store/example/exampleGenome.fa
+share/doc/snp_store/example/exampleReads.gff
+%%RM_I386%%share/doc/splazers/LICENSE
+%%RM_I386%%share/doc/splazers/README
+%%RM_I386%%share/doc/splazers/example/genome.fa
+%%RM_I386%%share/doc/splazers/example/reads.fa
+%%RM_I386%%share/doc/splazers/example/reads.fa.result
+share/doc/stellar/LICENSE
+share/doc/stellar/README
+share/doc/stellar/example/NC_001474.fasta
+share/doc/stellar/example/NC_001477.fasta
+share/doc/stellar/example/reads.fasta
+share/doc/tree_recon/LICENSE
+share/doc/tree_recon/README
+share/doc/tree_recon/example/example.dist
+share/doc/yara/LICENSE
+share/doc/yara/README.rst