aboutsummaryrefslogtreecommitdiffstats
path: root/cad/calculix
diff options
context:
space:
mode:
Diffstat (limited to 'cad/calculix')
-rw-r--r--cad/calculix/Makefile4
-rw-r--r--cad/calculix/files/patch-ccx_VER+src+Makefile6
-rw-r--r--cad/calculix/pkg-descr4
3 files changed, 10 insertions, 4 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index f7db85e1378d..d4ecc456c9c6 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -22,7 +22,6 @@ DIST_SUBDIR= calculix
MAINTAINER= maho@FreeBSD.org
COMMENT= A Three-Dimensional Structural Finite Element Program
-# These are required to build Crunchix (ccx)
BUILD_DEPENDS= ${LOCALBASE}/lib/libspooles.a:${PORTSDIR}/math/spooles \
${LOCALBASE}/lib/libarpack.a:${PORTSDIR}/math/arpack
LIB_DEPENDS= atlas.1:${PORTSDIR}/math/atlas
@@ -31,6 +30,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GL= yes
USE_REINPLACE= yes
BLAS_LIBS= -lf77blas -latlas
+
BROWSER?= mozilla
PSVIEWER?= gv
@@ -47,6 +47,8 @@ pre-everything::
pre-build:
@${REINPLACE_CMD} -e 's+%%FC%%+${FC}+g ; s+%%CC%%+${CC}+g ; \
+ s+%%PTHREAD_CFLAGS%%+${PTHREAD_CFLAGS} -DUSE_MT+g; \
+ s+%%PTHREAD_LIBS%%+${PTHREAD_LIBS}+g; \
s+%%BLAS_LIBS%%+${BLAS_LIBS}+ ; \
s+%%LOCALBASE%%+${LOCALBASE}+g;' \
${WRKSRC}/ccx_${PORTVERSION}/src/Makefile
diff --git a/cad/calculix/files/patch-ccx_VER+src+Makefile b/cad/calculix/files/patch-ccx_VER+src+Makefile
index 5d12fd47fd81..c1c0c36937f0 100644
--- a/cad/calculix/files/patch-ccx_VER+src+Makefile
+++ b/cad/calculix/files/patch-ccx_VER+src+Makefile
@@ -1,9 +1,9 @@
--- ccx_1.2/src/Makefile.orig Sun Jul 25 09:55:36 2004
-+++ ccx_1.2/src/Makefile Sat Dec 25 00:56:51 2004
++++ ccx_1.2/src/Makefile Wed Feb 2 15:53:46 2005
@@ -1,8 +1,8 @@
-CFLAGS = -Wall -O -I ../../../SPOOLES.2.2 -DARCH="Linux"
-FFLAGS = -Wall -O
-+CFLAGS += -I%%LOCALBASE%%/include/spooles -DARCH="FreeBSD"
++CFLAGS += -I%%LOCALBASE%%/include/spooles -DARCH="FreeBSD" %%PTHREAD_CFLAGS%%
+FFLAGS += -O
-CC=cc
@@ -28,7 +28,7 @@
ccx_1.2: $(OCCXMAIN) ccx_1.2.a $(LIBS)
- g77 -Wall -O -o $@ $(OCCXMAIN) ccx_1.2.a $(LIBS)
-+ $(FC) $(FFLAGS) -o $@ $(OCCXMAIN) ccx_1.2.a $(LIBS) -L$(DIR)
++ $(FC) %%PTHREAD_LIBS%% $(FFLAGS) -o $@ $(OCCXMAIN) ccx_1.2.a $(LIBS) -L$(DIR)
ccx_1.2.a: $(OCCXF) $(OCCXC)
ar vr $@ $?
diff --git a/cad/calculix/pkg-descr b/cad/calculix/pkg-descr
index 1a3cce5c3053..ba17ae1a44b3 100644
--- a/cad/calculix/pkg-descr
+++ b/cad/calculix/pkg-descr
@@ -11,3 +11,7 @@ Karlsson & Sorensen, Inc (HKS) and are used with kind permission from HKS.
Results obtained from CalculiX are in no way connected to ABAQUS.
WWW: http://www.calculix.de/
+
+note: By default, the single-threaded solver is used.his can be changed by
+setting the CCX_NPROC environment variable with the number of processor you want
+to use.
>-0/+538 |\ \ | |/ |/| | * fill initial stExtCodeHash testsextcodehashDimitry2018-11-091-0/+94 | * stExtCodeHash WIPDimitry2018-10-114-0/+444 * | sstore collision overwrite sstoreDimitry2018-10-252-0/+323 * | sstore xxx testsDimitry2018-10-1817-275/+2701 * | more test scenarios around test casesDimitry2018-10-1714-82/+1614 * | fill as blockchain testsDimitry2018-10-163-10/+201 * | sstore refund bugDimitry2018-10-151-0/+68 * | more sstore testsDimitry2018-10-154-0/+363 |/ * refill stCreate2 with new gasPriceDimitry2018-10-051-1/+1 * fix yml testsDimitry2018-10-035-10/+10 * blockchain test source updatesDimitry2018-10-022-0/+127 * correct Constantinople expect section in state testsDimitry2018-09-25190-406/+4645 * create2 smart init codeDimitry2018-09-141-0/+112 * (RevertDepthCreateAddressCollision) for CREATE2Dimitry2018-09-141-0/+150 * recursive create2Dimitry2018-09-141-0/+77 * push32 without bytes at the endDimitry2018-09-141-0/+62 * create2 on depth 1023 1024Dimitry2018-09-142-0/+159 * create2 oog in initDimitry2018-09-121-0/+85 * REVERT in CREATE2Dimitry2018-09-124-0/+292 * RevertDepthCreate2 OOGDimitry2018-09-111-0/+129 * returndatacopy after create2 testsDimitry2018-09-113-0/+190 * Merge pull request #500 from mattdean-digicatapult/add-new-touched-cleanup-casewinsvega2018-09-101-0/+73 |\ | * Add new touched cleanup caseMatthew Dean2018-09-101-0/+73 * | more create2 testsDimitry2018-09-084-4/+315 * | create2 check fields in init codeDimitry2018-09-081-0/+187 * | create2 call precompiles from init codeDimitry2018-09-061-0/+233 |/ * more create2 collision testsDimitry2018-09-057-11/+310 * refill collision testDimitry2018-09-041-3/+38 * create2 bounds + yoichi testsDimitry2018-09-045-0/+359 * create2 OOG testsDimitry2018-09-038-1/+541 * Suicide in create2 testsDimitry2018-08-312-0/+247 * create2 init code testsDimitry2018-08-282-0/+296 * create2 testDimitry2018-08-279-0/+865 * fix sar 2^256 0 testDimitry2018-08-081-3/+4 * sar00 testDimitry2018-07-271-0/+105 * sar 0 256-1 testDimitry2018-07-271-0/+106 * check returndatasize after failing createDimitry2018-07-061-0/+67 * check returndata after failing createDimitry2018-07-061-0/+75 * create failure due to deployment cost testsDimitry2018-07-035-0/+388 * fix remaining testsDimitry2018-05-181-9/+26 * restore ecmul testDimitry2018-05-151-3/+6 * fix more tests with coinbase touchDimitry2018-05-153-9/+50 * fix more tests with touch coinbaseDimitry2018-05-15