aboutsummaryrefslogtreecommitdiffstats
path: root/cad/freecad/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/freecad/Makefile')
-rw-r--r--cad/freecad/Makefile43
1 files changed, 22 insertions, 21 deletions
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index 83844e781536..4cd82faf1f32 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= FreeCAD
-DISTVERSION= 0.17.g20170104
+DISTVERSION= 0.17.g20170204
CATEGORIES= cad
MAINTAINER= tj+freebsd_ports@a13.fr
@@ -10,28 +10,29 @@ COMMENT= General purpose 3D CAD modeller
LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= pyside-rcc:devel/pyside-tools \
- swig:devel/swig13 \
+BUILD_DEPENDS= pyside-rcc:devel/pyside-tools \
+ swig:devel/swig13 \
${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3
-LIB_DEPENDS= libexpat.so:textproc/expat2 \
- libfreetype.so:print/freetype2 \
- libboost_python.so:devel/boost-python-libs \
- libpyside-python2.7.so:devel/pyside \
- libCoin.so:graphics/Coin \
- libpng16.so:graphics/png \
- libtiff.so:graphics/tiff \
- libvtkFiltersTexture-6.2.so:math/vtk6 \
- libTKernel.so:cad/opencascade \
- libSoQt.so:x11-toolkits/soqt \
- libxerces-c-3.1.so:textproc/xerces-c3 \
- libboost_thread.so:devel/boost-libs \
- libarea.so:devel/libarea \
- libmed.so:french/med \
- libshiboken-${PYTHON_VERSION}.so:devel/shiboken
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libfreetype.so:print/freetype2 \
+ libboost_python.so:devel/boost-python-libs \
+ libpyside-python2.7.so:devel/pyside \
+ libCoin.so:graphics/Coin \
+ libpng16.so:graphics/png \
+ libtiff.so:graphics/tiff \
+ libvtkFiltersTexture-6.2.so:math/vtk6 \
+ libTKernel.so:cad/opencascade \
+ libSoQt.so:x11-toolkits/soqt \
+ libxerces-c-3.1.so:textproc/xerces-c3 \
+ libboost_thread.so:devel/boost-libs \
+ libarea.so:devel/libarea \
+ libmed.so:french/med \
+ libshiboken-${PYTHON_VERSION}.so:devel/shiboken \
+ libhdf5.so:science/hdf5
RUN_DEPENDS= pivy>0:graphics/py-pivy
USE_GITHUB= yes
-GH_TAGNAME= f6f8363
+GH_TAGNAME= 36b7e03
USES= compiler:c++11-lib cmake:outsource jpeg python localbase
USE_XORG= ice sm x11 xext xt
@@ -62,9 +63,9 @@ post-patch:
pre-configure:
# To be removed when french/med will be built against science/hdf5
- ${REINPLACE_CMD} -e 's|find_package(HDF5 REQUIRED)|#find_package(HDF5 REQUIRED)|' \
+ @${REINPLACE_CMD} -e 's|find_package(HDF5 REQUIRED)|#find_package(HDF5 REQUIRED)|' \
${WRKSRC}/CMakeLists.txt
- ${REINPLACE_CMD} -e 's|<hdf5.h>|<hdf5-18/hdf5.h>|' \
+ @${REINPLACE_CMD} -e 's|<hdf5.h>|<hdf5-18/hdf5.h>|' \
${WRKSRC}/src/3rdParty/salomesmesh/inc/MED_Common.hxx
post-install: