aboutsummaryrefslogtreecommitdiffstats
path: root/cad/irsim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/irsim/Makefile')
-rw-r--r--cad/irsim/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/cad/irsim/Makefile b/cad/irsim/Makefile
index 12d08e74608c..28f29f0191a0 100644
--- a/cad/irsim/Makefile
+++ b/cad/irsim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= irsim
PORTVERSION= 9.5
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://mos.stanford.edu/group/magic/
EXTRACT_SUFX= .tar.Z
@@ -15,18 +16,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An event-driven logic-level simulator for MOS circuis
USE_XLIB= yes
+USE_REINPLACE= yes
MAN1= irsim.1
MAN3= irsim-analyzer.3
MAN5= netchange.5
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
# othewise patch will complain
post-extract:
@${FIND} ${WRKSRC} -name RCS | ${XARGS} ${RM} -rf
+post-patch:
+ @${EGREP} -lr '^#endif[^$$]' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|\(^#.*endif\).*|\1|g'
+
.include <bsd.port.post.mk>