aboutsummaryrefslogtreecommitdiffstats
path: root/cad/magic
diff options
context:
space:
mode:
Diffstat (limited to 'cad/magic')
-rw-r--r--cad/magic/Makefile14
-rw-r--r--cad/magic/distinfo4
-rw-r--r--cad/magic/files/patch-Makefile83
-rw-r--r--cad/magic/files/patch-commands__Makefile16
-rw-r--r--cad/magic/files/patch-textio__textioInt.h11
-rw-r--r--cad/magic/files/patch-textio__txInput.c89
-rw-r--r--cad/magic/pkg-plist8
7 files changed, 220 insertions, 5 deletions
diff --git a/cad/magic/Makefile b/cad/magic/Makefile
index c9a2fd274cb6..7a68e9578acb 100644
--- a/cad/magic/Makefile
+++ b/cad/magic/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= magic
-PORTVERSION= 7.5.213
+PORTVERSION= 7.5.214
CATEGORIES= cad
MASTER_SITES= http://opencircuitdesign.com/magic/archive/ \
http://fossies.org/linux/misc/
@@ -15,7 +15,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= An interactive editor for VLSI layouts
-LIB_DEPENDS+= BLT24.3:${PORTSDIR}/x11-toolkits/blt
+LICENSE= BSD
+
+LIB_DEPENDS= BLT24.3:${PORTSDIR}/x11-toolkits/blt
CONFIGURE_WRKSRC= ${WRKSRC}/scripts
@@ -29,7 +31,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR}
ALL_TARGET= tcllibrary
-MAKE_JOBS_UNSAFE=yes
+MAKE_JOBS_SAFE=yes
MAN1= ext2sim.1 ext2spice.1 extcheck.1 magic.1
MAN5= cmap.5 displays.5 dlys.5 dstyle.5 ext.5 glyphs.5 mag.5 \
@@ -38,6 +40,8 @@ MAN5= cmap.5 displays.5 dlys.5 dstyle.5 ext.5 glyphs.5 mag.5 \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+PORTSCOUT= limit:^7\.
+
.include <bsd.port.pre.mk>
post-patch:
@@ -56,4 +60,8 @@ post-patch:
@${REINPLACE_CMD} -e \
's|^#!.*|#!${WISH}|' ${WRKSRC}/tcltk/tkshell.tcl
+pre-build:
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} database/database.h)
+
.include <bsd.port.post.mk>
diff --git a/cad/magic/distinfo b/cad/magic/distinfo
index 4ca3e77f6a4b..ebd8bda6556f 100644
--- a/cad/magic/distinfo
+++ b/cad/magic/distinfo
@@ -1,2 +1,2 @@
-SHA256 (magic-7.5.213.tgz) = cacd14275ec13a008cb2dd0455e3bd5ff288be9060de0a805bb15b890ea42bf0
-SIZE (magic-7.5.213.tgz) = 3694855
+SHA256 (magic-7.5.214.tgz) = c809d4b497acfa69da729d06e0b4ceaab9b4eada89c38f79056f82db943667ab
+SIZE (magic-7.5.214.tgz) = 3758817
diff --git a/cad/magic/files/patch-Makefile b/cad/magic/files/patch-Makefile
new file mode 100644
index 000000000000..61b6f4d9fa51
--- /dev/null
+++ b/cad/magic/files/patch-Makefile
@@ -0,0 +1,83 @@
+--- Makefile.orig 2012-01-17 02:17:06.000000000 +0900
++++ Makefile 2012-01-17 02:18:32.000000000 +0900
+@@ -18,12 +18,10 @@
+ all: $(ALL_TARGET)
+
+ standard:
+- @echo --- errors and warnings logged in file make.log
+- @${MAKE} mains 2>&1 | tee -a make.log | egrep -i "(.c:|Stop.|---)"
++ ${MAKE} mains
+
+ tcl:
+- @echo --- errors and warnings logged in file make.log
+- @${MAKE} tcllibrary 2>&1 | tee -a make.log | egrep -i "(.c:|Stop.|---)"
++ ${MAKE} tcllibrary
+
+ force: clean all
+
+@@ -36,12 +34,12 @@
+ tcllibrary: database/database.h modules
+ @echo --- making Tcl shared libraries
+ for dir in ${PROGRAMS}; do \
+- (cd $$dir && ${MAKE} tcl-main); done
++ ${MAKE} -C $$dir tcl-main || exit 1 ; done
+
+ mains: database/database.h modules libs
+ @echo --- making main programs
+ for dir in ${PROGRAMS}; do \
+- (cd $$dir && ${MAKE} main); done
++ ${MAKE} -C $$dir main || exit 1 ; done
+
+ database/database.h: database/database.h.in
+ @echo --- making header file database/database.h
+@@ -50,30 +48,30 @@
+ modules:
+ @echo --- making modules
+ for dir in ${MODULES} ${PROGRAMS}; do \
+- (cd $$dir && ${MAKE} module); done
++ ${MAKE} -C $$dir module || exit 1 ; done
+
+ libs:
+ @echo --- making libraries
+ for dir in ${LIBRARIES}; do \
+- (cd $$dir && ${MAKE} lib); done
++ ${MAKE} -C $$dir lib || exit 1 ; done
+
+ depend: database/database.h
+ ${RM} */Depend
+ for dir in ${MODULES} ${UNUSED_MODULES} ${PROGRAMS}; do \
+- (cd $$dir && ${MAKE} depend); done
++ ${MAKE} -C $$dir depend || exit 1 ; done
+
+ install: $(INSTALL_TARGET)
+
+ install-magic:
+ @echo --- installing executable to $(DESTDIR)${BINDIR}
+ @echo --- installing runtime files to $(DESTDIR)${LIBDIR}
+- @${MAKE} install-real 2>&1 >> install.log
++ @${MAKE} install-real 2>&1
+
+ install-real: install-dirs
+ for dir in ${INSTALL_CAD_DIRS}; do \
+- (cd $$dir && ${MAKE} install); done
++ ${MAKE} -C $$dir install || exit 1 ; done
+ for dir in ${PROGRAMS}; do \
+- (cd $$dir && ${MAKE} install); done
++ ${MAKE} -C $$dir install || exit 1 ; done
+
+ install-tcl-dirs:
+ ${MAGICDIR}/scripts/mkdirs $(DESTDIR)${BINDIR} $(DESTDIR)${MANDIR} \
+@@ -86,11 +84,11 @@
+ install-tcl:
+ @echo --- installing executable to $(DESTDIR)${BINDIR}
+ @echo --- installing runtime files to $(DESTDIR)${LIBDIR}
+- @${MAKE} install-tcl-real 2>&1 >> install.log
++ @${MAKE} install-tcl-real
+
+ install-tcl-real: install-tcl-dirs
+ for dir in ${INSTALL_CAD_DIRS} ${PROGRAMS}; do \
+- (cd $$dir && ${MAKE} install-tcl); done
++ ${MAKE} -C $$dir install-tcl || exit 1 ; done
+
+ clean:
+ for dir in ${MODULES} ${PROGRAMS} ${TECH} ${UNUSED_MODULES}; do \
diff --git a/cad/magic/files/patch-commands__Makefile b/cad/magic/files/patch-commands__Makefile
new file mode 100644
index 000000000000..623312755884
--- /dev/null
+++ b/cad/magic/files/patch-commands__Makefile
@@ -0,0 +1,16 @@
+--- commands/Makefile.orig 2006-05-24 04:18:33.000000000 +0900
++++ commands/Makefile 2012-01-17 02:11:59.000000000 +0900
+@@ -10,12 +10,7 @@
+ # Force the module to regenerate the symbolic link in the readline
+ # directory, as it may be needed by CmdFI.c (in the non-Tcl compile)
+
+-module: ${MAGICDIR}/readline/readline lib${MODULE}.o
+-
+-${MAGICDIR}/readline/readline:
+- @if ( ! test -f ${MAGICDIR}/readline/readline ) ; then \
+- (cd ${MAGICDIR}/readline; ln -s `ls | grep readline` readline) ; \
+- fi
++module: lib${MODULE}.o
+
+ include ${MAGICDIR}/defs.mak
+ include ${MAGICDIR}/rules.mak
diff --git a/cad/magic/files/patch-textio__textioInt.h b/cad/magic/files/patch-textio__textioInt.h
new file mode 100644
index 000000000000..617b0d415dba
--- /dev/null
+++ b/cad/magic/files/patch-textio__textioInt.h
@@ -0,0 +1,11 @@
+--- textio/textioInt.h.orig 2006-04-11 07:03:13.000000000 +0900
++++ textio/textioInt.h 2012-01-17 02:37:35.000000000 +0900
+@@ -41,7 +41,7 @@
+ #define TX_CMD_PROMPT ":"
+
+ /* all of the state associated with a tty terminal */
+-#if !defined(SYSV) && !defined(CYGWIN)
++#if !defined(SYSV) && !defined(CYGWIN) && !defined(__FreeBSD__)
+ typedef struct {
+ struct sgttyb tx_i_sgtty;
+ struct tchars tx_i_tchars;
diff --git a/cad/magic/files/patch-textio__txInput.c b/cad/magic/files/patch-textio__txInput.c
new file mode 100644
index 000000000000..0194eb8423ab
--- /dev/null
+++ b/cad/magic/files/patch-textio__txInput.c
@@ -0,0 +1,89 @@
+--- textio/txInput.c.orig 2012-01-17 02:40:11.000000000 +0900
++++ textio/txInput.c 2012-01-17 02:45:26.000000000 +0900
+@@ -1204,14 +1204,14 @@
+ * ----------------------------------------------------------------------------
+ */
+
+-#if defined(SYSV) || defined(CYGWIN)
++#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
+
+ void
+ txGetTermState(buf)
+- struct termio *buf;
++ struct termios *buf;
+
+ {
+- ioctl( fileno( stdin ), TCGETA, buf);
++ ioctl( fileno( stdin ), TIOCGETA, buf);
+ }
+
+ #else
+@@ -1244,14 +1244,14 @@
+
+ void
+ txSetTermState(buf)
+-#if defined(SYSV) || defined(CYGWIN)
+- struct termio *buf;
++#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
++ struct termios *buf;
+ #else
+ txTermState *buf;
+ #endif /* SYSV */
+ {
+-#if defined(SYSV) || defined(CYGWIN)
+- ioctl( fileno(stdin), TCSETAF, buf );
++#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
++ ioctl( fileno(stdin), TIOCSETAF, buf );
+ #else
+ /* set the current terminal characteristics */
+ (void) ioctl(fileno(stdin), TIOCSETN, (char *) &(buf->tx_i_sgtty) );
+@@ -1279,13 +1279,13 @@
+
+ void
+ txInitTermRec(buf)
+-#if defined(SYSV) || defined(CYGWIN)
+- struct termio *buf;
++#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
++ struct termios *buf;
+ #else
+ txTermState *buf;
+ #endif /* SYSV */
+ {
+-#if defined(SYSV) || defined(CYGWIN)
++#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
+ buf->c_lflag = ISIG; /* raw: no echo and no processing, allow signals */
+ buf->c_cc[ VMIN ] = 1;
+ buf->c_cc[ VTIME ] = 0;
+@@ -1300,8 +1300,8 @@
+
+
+
+-#if defined(SYSV) || defined(CYGWIN)
+-struct termio closeTermState;
++#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
++struct termios closeTermState;
+ #else
+ static txTermState closeTermState;
+ #endif /* SYSV */
+@@ -1327,8 +1327,8 @@
+ void
+ txSaveTerm()
+ {
+-#if defined(SYSV) || defined(CYGWIN)
+- ioctl( fileno( stdin ), TCGETA, &closeTermState);
++#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
++ ioctl( fileno( stdin ), TIOCGETA, &closeTermState);
+ txEraseChar = closeTermState.c_cc[VERASE];
+ txKillChar = closeTermState.c_cc[VKILL];
+ TxEOFChar = closeTermState.c_cc[VEOF];
+@@ -1368,8 +1368,8 @@
+ void
+ TxSetTerminal()
+ {
+-#if defined(SYSV) || defined(CYGWIN)
+- struct termio buf;
++#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
++ struct termios buf;
+ #else
+ txTermState buf;
+ #endif /* SYSV */
diff --git a/cad/magic/pkg-plist b/cad/magic/pkg-plist
index 90dcd7d81f5b..b8f03040939b 100644
--- a/cad/magic/pkg-plist
+++ b/cad/magic/pkg-plist
@@ -232,9 +232,11 @@ lib/magic/doc/tuttcl3.ps
lib/magic/doc/tuttcl4.ps
lib/magic/doc/tuttcl5.ps
lib/magic/doc/tutwrl1.ps
+lib/magic/sys/.magicrc
lib/magic/sys/bw.glyphs
lib/magic/sys/color.glyphs
lib/magic/sys/gdsquery.tech
+lib/magic/sys/magicps.pro
lib/magic/sys/minimum.tech
lib/magic/sys/mos.24bit.dstyle
lib/magic/sys/mos.24bit.std.cmap
@@ -255,6 +257,11 @@ lib/magic/sys/windows11.glyphs
lib/magic/sys/windows14.glyphs
lib/magic/sys/windows22.glyphs
lib/magic/sys/windows7.glyphs
+lib/magic/tcl/bitmaps/down.xbm
+lib/magic/tcl/bitmaps/left.xbm
+lib/magic/tcl/bitmaps/right.xbm
+lib/magic/tcl/bitmaps/up.xbm
+lib/magic/tcl/bitmaps/zoom.xbm
lib/magic/tcl/console.tcl
lib/magic/tcl/exttosim.so
lib/magic/tcl/exttospice.so
@@ -263,6 +270,7 @@ lib/magic/tcl/magicdnull
lib/magic/tcl/magicexec
lib/magic/tcl/mazeroute.tcl
lib/magic/tcl/strip_reflibs.tcl
+lib/magic/tcl/tclmagic.so
lib/magic/tcl/techbuilder.tcl
lib/magic/tcl/tkcon.tcl
lib/magic/tcl/tkshell.tcl
antw44/cgit/gsoc2013-evolution/commit/?h=EVOLUTION_2_30_3&id=7c638e6c9b9a4264c15fead81522b2643c07e6bf'>Updated Lithuanian translation.Žygimantas Beručka2009-03-032-3483/+3786 * Translation updated.Gabor Kelemen2009-03-032-1/+5 * Updated British English translation.Philip Withnall2009-03-032-5128/+12616 * Post-release version bump.Matthew Barnes2009-03-032-2/+6 * Evolution 2.25.92 releaseEVOLUTION_2_25_92Matthew Barnes2009-03-033-1/+82 * Added entries for Oriya Language TranslationManoj Kumar Giri2009-03-021-0/+4 * Updated Oriya TranslationManoj Kumar Giri2009-03-021-6205/+9281 * Committed Translation by Sweta KothariSweta Kothari2009-03-022-354/+351 * Revert evolution revision 37063 (workaround for bug 563867).Matt McCutchen2009-03-025-38/+12 * Updated Dutch translation by Wouter Bolsterlee.Wouter Bolsterlee2009-03-022-3356/+3814 * sv.po: Updated Swedish translationDaniel Nylander2009-03-022-694/+691 * Translation updated by Mattias PõldaruPriit Laes2009-03-012-1803/+7588 * Translation updated by Ivar SmolinPriit Laes2009-03-012-5/+9 * Translation updated.Gabor Kelemen2009-03-012-2/+6 * ** Fixes bug #572950Matthew Barnes2009-02-278-9/+36 * Correcting my last ChangeLog entryAndre Klapper2009-02-271-1/+1 * Remove deprecated gtk_combo_set_case_sensitive() call as FALSE IS alreadyAndre Klapper2009-02-272-1/+6 * remove deprecated and commented code.Andre Klapper2009-02-262-5/+5 * Chenthill Palanisamy <pchenthill@novell.com> ** Part of fix for bug #573198 ...Suman Manjunath2009-02-262-1/+9 * ** Fix for bug #558366Milan Crha2009-02-252-0/+9 * ** Fix for bug #238346Milan Crha2009-02-252-45/+93 * ** Fix for bug #529037Milan Crha2009-02-252-0/+18 * ** Fix for bug #572975Milan Crha2009-02-253-15/+33 * ** Fix for bug #572399Milan Crha2009-02-252-6/+14 * ** Fix for bug #572268Milan Crha2009-02-252-3/+15 * ** Part of fix for bug #563212Milan Crha2009-02-252-9/+47 * ** Fix for bug #561465Milan Crha2009-02-252-0/+8 * ** Fix for bug #559719Milan Crha2009-02-254-13/+42 * ** Fix for bug #559027Milan Crha2009-02-252-2/+11 * ** Fix for bug #551470Milan Crha2009-02-253-4/+30 * ** Fixes bug #572962Matthew Barnes2009-02-253-7/+16 * Add myself as a Shell maintainer, with Srini's permission.Matthew Barnes2009-02-252-0/+6 * ** Fix for bug #572903Philip Withnall2009-02-252-3/+11 * Updated British English translation.Philip Withnall2009-02-242-3639/+4038 * ** Fix for bug #572543Milan Crha2009-02-234-4/+20 * Updated Catalan translation by David PlanellaGil Forcada Codinachs2009-02-232-281/+279 * Make it use the proper action. Patch by Paweł ZembrzuskiTobias Mueller2009-02-222-1/+8 * Updated French translation by Bruno Brouard and Claude Paroz.Claude Paroz2009-02-212-3190/+3430 * Updated Thai translation.Theppitak Karoonboonyanan2009-02-202-42/+46 * ** Fix for bug #567949Milan Crha2009-02-203-6/+16 * Updated be@latin.poIhar Hrachyshka2009-02-192-357/+204 * Rats. gtk_status_icon_set_tooltip_text() is only in 2.16.Matthew Barnes2009-02-192-1/+7 * ** Fixes part of bug #572348Matthew Barnes2009-02-197-7/+29 * Remove useless and deprecated gtk_layout_freeze and gtk_layout_thaw calls.Andre Klapper2009-02-192-11/+6 * Migrate from deprecated gtk_window_set_policy to gtk_window_set_resizableAndre Klapper2009-02-192-1/+6 * Updated Thai translation.Theppitak Karoonboonyanan2009-02-182-2985/+3309 * Updated be@latin.poIhar Hrachyshka2009-02-182-5324/+6825 * Updated Korean translationChangwoo Ryu2009-02-182-616/+728 * Added image in Basque language. Images are: account_editor_a.pngInaki Larranaga Murgoitio2009-02-18120-0/+64 * 2.25.91Chao-Hsiung Liao2009-02-173-561/+591 * Updated Japanese translation.Takeshi AIHANA2009-02-172-4337/+4606 * Closes bug 569519Simos Xenitellis2009-02-172-5/+5 * Updated Greek translation (Marios Zindilis)Simos Xenitellis2009-02-172-3397/+3926 * Added Basque translation. Added 'eu' to DOC_LINGUAS.Inaki Larranaga Murgoitio2009-02-162-1/+6 * svn path=/trunk/; revision=37277Iñaki Larrañaga Murgoitio2009-02-161-0/+9303 * ** Fix for bug #571721Milan Crha2009-02-162-0/+7 * ** Fix for bug #550114Milan Crha2009-02-1611-36/+94 * Committed Translation by Sweta KothariSweta Kothari2009-02-162-103/+107 * ** Fixes bug #571734Matthew Barnes2009-02-152-3/+5 * Updated Danish translationKenneth Nielsen2009-02-152-2885/+3160 * Updated Czech translation by Jiri Eischmann.Petr Kovar2009-02-152-2806/+2959 * Updated Spanish translationJorge Gonzalez Gonzalez2009-02-142-19/+21 * ** Fixes part of bug #564229Matthew Barnes2009-02-144-7/+21 * Translation updated.Gabor Kelemen2009-02-142-397/+292 * ** Fixes bug #571625Chow Loong Jin2009-02-143-10/+14 * svn path=/trunk/; revision=37256Iñaki Larrañaga Murgoitio2009-02-121-201/+103 * Committed Translation by Sweta KothariSweta Kothari2009-02-122-134/+18 * Updated Basque translation.Inaki Larranaga Murgoitio2009-02-122-3640/+4039 * ** Fix for bug #404232Milan Crha2009-02-124-2/+19 * ** Fix for bug #567089Milan Crha2009-02-122-1/+13 * Substitute some deprecated gtk+ functions.Andre Klapper2009-02-1210-19/+41 * Updated Brazilian Portuguese translation by Andre Gondim.Jonh Wendell2009-02-112-558/+317 * ** Fix for bug #569700Milan Crha2009-02-112-0/+11 * ** Fix for bug #333716Milan Crha2009-02-112-9/+15 * ** Removed unused figures (bug #552695)Matthew Barnes2009-02-1148-47/+7 * Format signature/encryption information nicer.Milan Crha2009-02-112-3/+11 * Updated Finnish translationIlkka Tuohela2009-02-102-257/+293 * Updated Catalan translation by David PlanellaGil Forcada Codinachs2009-02-102-858/+1006 * Do not use non-zero page size in an adjustment, it's deprecated now.Milan Crha2009-02-092-1/+6 * ** Part of fix for bug #555888Milan Crha2009-02-097-204/+82 * ** Fix for bug #548623Milan Crha2009-02-094-4/+38 * Updated Norwegian bokmål translation.Kjartan Maraas2009-02-072-192/+203 * Updated Spanish translationJorge Gonzalez Gonzalez2009-02-072-17/+30 * Updated Vietnamese translationClytie Siddall2009-02-062-6463/+7020 * ** Part of fix for bug #554458Milan Crha2009-02-062-7/+12 * Committed Translation by Sweta KothariSweta Kothari2009-02-052-4598/+5137 * ** Fix for bug #568176Gilles Dartiguelongue2009-02-052-26/+56 * Include <mono/metadata/mono-config.h> to fix an implicit-function-declaration...Suman Manjunath2009-02-052-0/+6 * 2.25.91Chao-Hsiung Liao2009-02-043-7401/+7768 * Use -mwindows on Windows to build a "GUI" executable.Tor Lillqvist2009-02-042-0/+9 * Revert accidental commit.Tor Lillqvist2009-02-042-7/+0 * Set MWINDOWS to -mwindows on Windows. AC_SUBST it.Tor Lillqvist2009-02-042-0/+7 * Updated Spanish translationJorge Gonzalez Gonzalez2009-02-041-35/+36 * Mark a string for translation. Fixes bug #570364Gabor Kelemen2009-02-032-1/+7 * ** Fix for bug #569986Srinivasa Ragavan2009-02-035-1/+14 * Evolution 2.25.90 releaseEVOLUTION_2_25_90Srinivasa Ragavan2009-02-033-1/+54 * Updated Spanish translationJorge Gonzalez Gonzalez2009-02-032-229/+249 * Reviewed by Srinivasa Ragavan <sragavan@novell.com>Takao Fujiwara2009-02-033-3/+38 * Srinivasa Ragavan <sragavan@novell.com> ** Fix for bug #548787 (Enable CnP f...Suman Manjunath2009-02-022-0/+25 * Patch from Matt McCutchen 2: Fix for bug #567935 (Don't use an uninitialized ...Suman Manjunath2009-02-022-3/+10 * Fix compiler warnings.Matthew Barnes2009-02-0212-13/+34 * EPLugin : Added new hook point.Johnny Jacob2009-02-024-0/+54 * Updated Czech translation by Jiri Eischmann.Petr Kovar2009-02-022-4807/+9889 * ** Disable debug macros (#define d(x) x) throughout. (#569638)Matthew Barnes2009-02-0113-12/+15 * Translation updated.Gabor Kelemen2009-02-012-3601/+4101 * updating for Punjabi by A S AlamAmanpreet Singh Alam2009-01-311-323/+240 * sv.po: Updated Swedish translationDaniel Nylander2009-01-312-2965/+3217 * updating for Punjabi by A S AlamAmanpreet Singh Alam2009-01-31