aboutsummaryrefslogtreecommitdiffstats
path: root/cad/meshlab
diff options
context:
space:
mode:
Diffstat (limited to 'cad/meshlab')
-rw-r--r--cad/meshlab/Makefile3
-rw-r--r--cad/meshlab/files/patch-meshlab_meshlab.pro9
2 files changed, 11 insertions, 1 deletions
diff --git a/cad/meshlab/Makefile b/cad/meshlab/Makefile
index 46f90ebf5f0e..9fde058248ea 100644
--- a/cad/meshlab/Makefile
+++ b/cad/meshlab/Makefile
@@ -8,6 +8,7 @@
PORTNAME= meshlab
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/MeshLab%20v${PORTVERSION}/
DISTNAME= MeshLabSrc_AllInc_v123a
@@ -16,7 +17,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= A tool for processing and editing 3D triangular meshes
-USE_GL= glew
+USE_GL= glew glu
USE_QT_VER= 4
QT_COMPONENTS= qmake corelib gui xml opengl network moc uic rcc
diff --git a/cad/meshlab/files/patch-meshlab_meshlab.pro b/cad/meshlab/files/patch-meshlab_meshlab.pro
new file mode 100644
index 000000000000..542c3f15ed30
--- /dev/null
+++ b/cad/meshlab/files/patch-meshlab_meshlab.pro
@@ -0,0 +1,9 @@
+--- meshlab/meshlab.pro~ 2012-05-20 01:14:08.000000000 -0300
++++ meshlab/meshlab.pro 2012-05-20 01:14:53.000000000 -0300
+@@ -1,3 +1,6 @@
++# Qt 4.8 does not add -lGLU automatically with QT=opengl anymore
++LIBS += -lGLU
++
+ VCGDIR = ../../../vcglib
+ GLEWDIR = ../external/glew-1.5.1
+ #CONFIG += debug_and_release