aboutsummaryrefslogtreecommitdiffstats
path: root/cad/tkgate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/tkgate/Makefile')
-rw-r--r--cad/tkgate/Makefile36
1 files changed, 12 insertions, 24 deletions
diff --git a/cad/tkgate/Makefile b/cad/tkgate/Makefile
index 3ce9a5ae5cd7..164451dcb29c 100644
--- a/cad/tkgate/Makefile
+++ b/cad/tkgate/Makefile
@@ -2,12 +2,9 @@
# $FreeBSD$
PORTNAME= tkgate
-PORTVERSION= 1.8.7
-PORTREVISION= 4
+DISTVERSION= 2.0-b10
CATEGORIES= cad
-MASTER_SITES= http://ark2.media.eng.hokudai.ac.jp/microprocessor/ \
- http://www.info.kindai.ac.jp/LC/TkGate/ \
- http://www.tkgate.org/downloads/
+MASTER_SITES= http://www.tkgate.org/downloads/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
@@ -15,32 +12,23 @@ COMMENT= Tcl/Tk based digital circuit editor and simulator
LICENSE= GPLv2 # (or later)
-USE_XORG= x11
-USE_TCL_BUILD= yes
-USE_TK_BUILD= yes
-USE_TCL= yes
-USE_TK= yes
-USE_IMAKE= yes
+GNU_CONFIGURE= yes
+USES= iconv
+USE_TK= 84+
+INVALID_TK_VER= 86
MAKE_JOBS_SAFE= yes
-PLIST_SUB= VERSION="${PORTVERSION}"
-
-MAN1= gmac.1 tkgate.1
+MAN1= gmac.1 tkgate.1 verga.1
TKGATE_IPATH= -I${TK_INCLUDEDIR} -I${TCL_INCLUDEDIR}
TKGATE_LIBS= -ltk${TK_VER:S/.//} -ltcl${TCL_VER:S/.//} -lX11 -lm
post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/wish|${WISH}|g' ${WRKSRC}/scripts/tree.tcl
@${REINPLACE_CMD} -e \
- 's|/usr/X11R6|${LOCALBASE}|g ; \
- s|dl socket nsl||g ; \
- /^#define TKGATE_IPATH/s|-I.*|${TKGATE_IPATH}|g ; \
- /^#define TKGATE_LIBS/s|-l.*|${TKGATE_LIBS}|g ; \
- /^#define TKGATE_GCCFLAGS/s|-O||g ; \
- /^#define TKGATE_CC/s|gcc|${CC}|g' ${WRKSRC}/config.h
-.for file in tree.tcl elistbox.tcl
- @${REINPLACE_CMD} -e \
- 's|^#!.*|#!${WISH}|g' ${WRKSRC}/scripts/${file}
-.endfor
+ 's|%%TCL_VER%%|${TCL_VER}|g; \
+ s|%%TCL_INCLUDEDIR%%|${TCL_INCLUDEDIR}|g; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>