aboutsummaryrefslogtreecommitdiffstats
path: root/cad/xcircuit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/xcircuit/Makefile')
-rw-r--r--cad/xcircuit/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index ccbaf7061293..de9bd20b67d5 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -1,32 +1,30 @@
# New ports collection makefile for: xcircuit
-# Version required: 1.7
+# Version required: 2.0a10
# Date created: 3 Apr 1998
# Whom: giffunip@asme.org
#
# $FreeBSD$
#
-DISTNAME= xcircuit-1.7
+DISTNAME= xcircuit-2.0a10
CATEGORIES= cad
-MASTER_SITES= ftp://bach.ece.jhu.edu/pub/tim/ \
- ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR=apps/circuits
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ ftp://bach.ece.jhu.edu/pub/tim/
+MASTER_SITE_SUBDIR= apps/circuits
MAINTAINER= ports@FreeBSD.org
-BROKEN='bad MD5 checksum'
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
USE_IMAKE= yes
XMKMF= xmkmf
-ALL_TARGET=
-INSTALL_TARGET= install install.man
MAN1= xcircuit.1
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/xcircuit
- ${CP} ${WRKSRC}/examples/*.ps ${PREFIX}/share/examples/xcircuit
+ @${MKDIR} ${PREFIX}/share/examples/xcircuit
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${PREFIX}/share/examples/xcircuit
.endif
.include <bsd.port.mk>