aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
Diffstat (limited to 'cad')
-rw-r--r--cad/pcb/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/cad/pcb/Makefile b/cad/pcb/Makefile
index 04c7b907acdd..d75284d848e2 100644
--- a/cad/pcb/Makefile
+++ b/cad/pcb/Makefile
@@ -41,6 +41,11 @@ GTK_DESC= GIMP ToolKit widgets
NONE_DESC= No GUI support
NO_STAGE= yes
+
+.for a in ia64 powerpc sparc64
+BROKEN_${a}= Does not compile on ia64, powerpc, or sparc64
+.endfor
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -83,10 +88,4 @@ MAN1= pcb.1
CONFIGURE_ARGS+= --disable-doc
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>